summaryrefslogtreecommitdiff
path: root/dev-ml/jingoo/jingoo-1.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/jingoo/jingoo-1.4.2.ebuild')
-rw-r--r--dev-ml/jingoo/jingoo-1.4.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/jingoo/jingoo-1.4.2.ebuild b/dev-ml/jingoo/jingoo-1.4.2.ebuild
new file mode 100644
index 000000000000..4164b805b6a0
--- /dev/null
+++ b/dev-ml/jingoo/jingoo-1.4.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="OCaml template engine almost compatible with Jinja2."
+HOMEPAGE="https://github.com/tategakibunko/jingoo"
+SRC_URI="https://github.com/tategakibunko/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/ppx_deriving
+ dev-ml/uucp
+ dev-ml/uutf
+ dev-ml/re
+ dev-ml/menhir"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"