summaryrefslogtreecommitdiff
path: root/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r2.ebuild')
-rw-r--r--dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r2.ebuild b/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r2.ebuild
new file mode 100644
index 000000000000..e3060e6255dc
--- /dev/null
+++ b/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="gsl"
+inherit dune
+
+MY_P=${P/-ocaml/}
+DESCRIPTION="OCaml bindings for the GSL library (successor of dev-ml/ocamlgsl)"
+HOMEPAGE="https://github.com/mmottl/gsl-ocaml"
+SRC_URI="https://github.com/mmottl/${PN}/releases/download/${PV}/${MY_P}.tbz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/dune-configurator
+ >=sci-libs/gsl-1.19:="
+RDEPEND="${DEPEND}"
+BDEPEND="<dev-lang/ocaml-5"
+
+# DOCS=( CHANGES.txt README.md NOTES.md TODO.md )