summaryrefslogtreecommitdiff
path: root/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild')
-rw-r--r--dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild b/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild
new file mode 100644
index 000000000000..694f13126426
--- /dev/null
+++ b/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml bindings for the GSL library (successor of dev-ml/ocamlgsl)"
+HOMEPAGE="https://github.com/mmottl/gsl-ocaml"
+SRC_URI="https://github.com/mmottl/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND=">=sci-libs/gsl-1.19"
+RDEPEND="${DEPEND}
+ !dev-ml/ocamlgsl"
+
+DOCS=( CHANGES.txt README.md NOTES.md TODO.md )
+
+src_prepare() {
+ oasis_configure_opts="$(use_enable examples)"
+}