summaryrefslogtreecommitdiff
path: root/dev-ml/gen/gen-1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/gen/gen-1.0-r1.ebuild')
-rw-r--r--dev-ml/gen/gen-1.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/gen/gen-1.0-r1.ebuild b/dev-ml/gen/gen-1.0-r1.ebuild
new file mode 100644
index 000000000000..d836571a87d6
--- /dev/null
+++ b/dev-ml/gen/gen-1.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Iterators for OCaml, both restartable and consumable"
+HOMEPAGE="https://github.com/c-cube/gen/"
+SRC_URI="https://github.com/c-cube/gen/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # tests fail > unused-open
+
+DEPEND="
+ dev-ml/dune-configurator:=
+ dev-ml/seq:="
+RDEPEND="${DEPEND}"
+# BDEPEND="test? ( dev-ml/qtest )"