summaryrefslogtreecommitdiff
path: root/dev-ml/fpath/fpath-0.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/fpath/fpath-0.7.3.ebuild')
-rw-r--r--dev-ml/fpath/fpath-0.7.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/fpath/fpath-0.7.3.ebuild b/dev-ml/fpath/fpath-0.7.3.ebuild
new file mode 100644
index 000000000000..13e85c27b103
--- /dev/null
+++ b/dev-ml/fpath/fpath-0.7.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="File system paths for OCaml"
+HOMEPAGE="https://erratique.ch/software/fpath https://github.com/dbuenzli/fpath"
+SRC_URI="https://erratique.ch/software/fpath/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-ml/result:=
+ dev-ml/astring:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}