summaryrefslogtreecommitdiff
path: root/dev-ml/fmt/fmt-0.8.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/fmt/fmt-0.8.9.ebuild')
-rw-r--r--dev-ml/fmt/fmt-0.8.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/fmt/fmt-0.8.9.ebuild b/dev-ml/fmt/fmt-0.8.9.ebuild
new file mode 100644
index 000000000000..b3fecea7226b
--- /dev/null
+++ b/dev-ml/fmt/fmt-0.8.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib opam
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="https://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="https://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/result:=[ocamlopt]
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]
+ dev-ml/cmdliner:=[ocamlopt]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-ml/topkg-0.9
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}