summaryrefslogtreecommitdiff
path: root/dev-ml/expect_test_helpers_core/expect_test_helpers_core-0.15.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/expect_test_helpers_core/expect_test_helpers_core-0.15.0-r1.ebuild')
-rw-r--r--dev-ml/expect_test_helpers_core/expect_test_helpers_core-0.15.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/expect_test_helpers_core/expect_test_helpers_core-0.15.0-r1.ebuild b/dev-ml/expect_test_helpers_core/expect_test_helpers_core-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..e161e379ff4d
--- /dev/null
+++ b/dev-ml/expect_test_helpers_core/expect_test_helpers_core-0.15.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Helpers for writing expectation tests"
+HOMEPAGE="https://github.com/janestreet/expect_test_helpers_core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:${SLOT}
+ dev-ml/core:${SLOT}
+ dev-ml/ppx_jane:${SLOT}
+ dev-ml/stdio:${SLOT}
+ dev-ml/sexp_pretty:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""