summaryrefslogtreecommitdiff
path: root/dev-ml/dune/dune-2.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/dune/dune-2.7.1.ebuild')
-rw-r--r--dev-ml/dune/dune-2.7.1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-ml/dune/dune-2.7.1.ebuild b/dev-ml/dune/dune-2.7.1.ebuild
deleted file mode 100644
index 9d729d98b8a9..000000000000
--- a/dev-ml/dune/dune-2.7.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multiprocessing
-
-DESCRIPTION="A composable build system for OCaml"
-HOMEPAGE="https://github.com/ocaml/dune"
-SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
-IUSE="test"
-
-DEPEND=">=dev-lang/ocaml-4.08:=
- <dev-lang/ocaml-4.12"
-RDEPEND="${DEPEND}
- !dev-ml/jbuilder"
-
-RESTRICT="test"
-
-src_configure() {
- :
-}
-
-src_compile() {
- ocaml bootstrap.ml || die
- ./dune.exe build -p "${PN}" --profile dune-bootstrap -j $(makeopts_jobs) || die
-}
-
-src_install() {
- default
- mv "${ED}"/usr/doc "${ED}"/usr/share/doc/${PF} || die
- mv "${ED}"/usr/man "${ED}"/usr/share/man || die
-}