summaryrefslogtreecommitdiff
path: root/dev-ml/dose3
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/dose3')
-rw-r--r--dev-ml/dose3/Manifest3
-rw-r--r--dev-ml/dose3/dose3-5.0.1.ebuild64
-rw-r--r--dev-ml/dose3/metadata.xml13
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-ml/dose3/Manifest b/dev-ml/dose3/Manifest
new file mode 100644
index 000000000000..2fdec63adfe8
--- /dev/null
+++ b/dev-ml/dose3/Manifest
@@ -0,0 +1,3 @@
+DIST dose3-5.0.1.tar.gz 297433 BLAKE2B 74ae954604f26398f091b4f14d2a633132ae62102f52af13284af27e41cd7c47afb1b533b0821a8921ba33fa6658e94b3bb6bf5f104f48881a50e14517cd65e2 SHA512 e66526319446054041f138ee2633043d0832089f6a554cf566a28de899d10383acfb1aa6bf1a368811602939676510933a7d2404fd34dbeba15045b458f5af84
+EBUILD dose3-5.0.1.ebuild 1548 BLAKE2B 2e2348459b998cc2350787d7c41ebe1a7c7d2ee3f5eb4de538b2c62bb2854ba9ee354441a3b2cf6bdb0e0cc28c1d6e7de8b61ea6a44e0f91dbe5ddba0f2d9d40 SHA512 3b8054200e7077eafe369f339ad65aadde15ea0b75da3b1a28beffb742d90ce9915fb02061145bd9b10163372af4cbe05ea034280d01888e5c03f5f65cbc09c9
+MISC metadata.xml 477 BLAKE2B bab8c4dcccf018fc386a04eff221a119adaf4d322ebe20544a3287f3ec14d418f44f09c39ce9608e50d895db4b9b8d09d830c85d57dd33c69534db3e74aae114 SHA512 899e3f1db5541688a15afb5830f7f2578ec413273e1c7f0db1cc31f1695f01ea42df4377db4fda2f5e4a6703166217bcb58aebf417a99b086dbf7f6ff73a0f95
diff --git a/dev-ml/dose3/dose3-5.0.1.ebuild b/dev-ml/dose3/dose3-5.0.1.ebuild
new file mode 100644
index 000000000000..3d2b19a0b099
--- /dev/null
+++ b/dev-ml/dose3/dose3-5.0.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${P/_beta/-beta}"
+DESCRIPTION="Library to perform analysis on package repositories"
+HOMEPAGE="http://www.mancoosi.org/software/ https://gforge.inria.fr/projects/dose"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/36063/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt parmap zip bzip2 xml curl rpm4 test"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/cudf:=
+ >=dev-ml/extlib-1.7.0:=
+ dev-ml/ocaml-re:=
+ dev-ml/cppo:=
+ parmap? ( dev-ml/parmap:= )
+ zip? ( dev-ml/camlzip:= )
+ bzip2? ( dev-ml/camlbz2:= )
+ >=dev-ml/ocamlgraph-1.8.6:=
+ xml? ( dev-ml/ocaml-expat:= dev-ml/xml-light:= )
+ curl? ( dev-ml/ocurl:= )
+ rpm4? ( app-arch/rpm )
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ test? ( dev-python/pyyaml[libyaml] )
+"
+# missing test data
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -e 's/INSTALLOPTS=-s/INSTALLOPTS=/' -i Makefile.config.in || die
+}
+
+src_configure() {
+ econf \
+ $(use ocamlopt || echo "--with-bytecodeonly") \
+ $(use parmap && echo "--with-parmap") \
+ $(use zip && echo "--with-zip") \
+ $(use bzip2 && echo "--with-bz2") \
+ $(use xml && echo "--with-xml") \
+ $(use curl && echo "--with-curl") \
+ $(use rpm4 && echo "--with-rpm4")
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR="${ED}/usr/bin" install || die
+ dodoc CHANGES CREDITS README.architecture TODO
+}
diff --git a/dev-ml/dose3/metadata.xml b/dev-ml/dose3/metadata.xml
new file mode 100644
index 000000000000..e4749fd2b534
--- /dev/null
+++ b/dev-ml/dose3/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <use>
+ <flag name="parmap">Adds multi-core CPU support via <pkg>dev-ml/parmap</pkg>.</flag>
+ <flag name="zip">Adds support for handling zip files.</flag>
+ <flag name="rpm4">Adds support for handling rpm4 files.</flag>
+ </use>
+</pkgmetadata>