summaryrefslogtreecommitdiff
path: root/dev-ml/cppo/cppo-1.6.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/cppo/cppo-1.6.9.ebuild')
-rw-r--r--dev-ml/cppo/cppo-1.6.9.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ml/cppo/cppo-1.6.9.ebuild b/dev-ml/cppo/cppo-1.6.9.ebuild
new file mode 100644
index 000000000000..d5be2914fca3
--- /dev/null
+++ b/dev-ml/cppo/cppo-1.6.9.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="https://github.com/ocaml-community/cppo/"
+SRC_URI="https://github.com/ocaml-community/cppo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-ml/ocamlbuild
+ dev-ml/findlib:="
+DEPEND="${RDEPEND}"