summaryrefslogtreecommitdiff
path: root/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild')
-rw-r--r--dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild b/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
index 8133a505cfb0..e55cdec3ea78 100644
--- a/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
@@ -18,7 +18,8 @@ IUSE="+ocamlopt"
DEPEND="dev-lang/ocaml:0/$(ver_cut 1-2)[ocamlopt?]"
RDEPEND="${DEPEND}"
DEPEND="${DEPEND}
- dev-ml/ocamlbuild"
+ dev-ml/ocamlbuild
+ dev-ml/findlib:="
src_configure() {
./configure \
@@ -38,4 +39,9 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install install-META
dodoc CHANGES.md README.md
+
+ if has_version ">=dev-ml/findlib-1.9" ; then
+ # See bug #803275
+ rm "${ED}/usr/$(get_libdir)/ocaml/camlp4/META" || die
+ fi
}