summaryrefslogtreecommitdiff
path: root/dev-ml/camlidl/files/nowarn.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlidl/files/nowarn.patch')
-rw-r--r--dev-ml/camlidl/files/nowarn.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-ml/camlidl/files/nowarn.patch b/dev-ml/camlidl/files/nowarn.patch
new file mode 100644
index 000000000000..8b457cf7ed1e
--- /dev/null
+++ b/dev-ml/camlidl/files/nowarn.patch
@@ -0,0 +1,13 @@
+Index: camlidl-1.05/compiler/Makefile
+===================================================================
+--- camlidl-1.05.orig/compiler/Makefile
++++ camlidl-1.05/compiler/Makefile
+@@ -29,7 +29,7 @@ PROG=camlidl$(EXE)
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(OCAMLC) -o $(PROG) $(OBJS)
++ $(OCAMLC) -w -a -o $(PROG) $(OBJS)
+
+ clean::
+ rm -f $(PROG)