summaryrefslogtreecommitdiff
path: root/dev-ml/biniou/biniou-1.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/biniou/biniou-1.2.2.ebuild')
-rw-r--r--dev-ml/biniou/biniou-1.2.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ml/biniou/biniou-1.2.2.ebuild b/dev-ml/biniou/biniou-1.2.2.ebuild
new file mode 100644
index 000000000000..74bf4a9d195b
--- /dev/null
+++ b/dev-ml/biniou/biniou-1.2.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/biniou/"
+SRC_URI="https://github.com/ocaml-community/biniou/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.02.3:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"