summaryrefslogtreecommitdiff
path: root/dev-ml/biniou/biniou-1.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/biniou/biniou-1.2.2-r1.ebuild')
-rw-r--r--dev-ml/biniou/biniou-1.2.2-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/biniou/biniou-1.2.2-r1.ebuild b/dev-ml/biniou/biniou-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..45538d1c0312
--- /dev/null
+++ b/dev-ml/biniou/biniou-1.2.2-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/biniou/"
+SRC_URI="https://github.com/ocaml-community/biniou/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3:=[ocamlopt?]
+ dev-ml/camlp-streams:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"