summaryrefslogtreecommitdiff
path: root/dev-ml/base_quickcheck/base_quickcheck-0.14.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/base_quickcheck/base_quickcheck-0.14.1.ebuild')
-rw-r--r--dev-ml/base_quickcheck/base_quickcheck-0.14.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/base_quickcheck/base_quickcheck-0.14.1.ebuild b/dev-ml/base_quickcheck/base_quickcheck-0.14.1.ebuild
new file mode 100644
index 000000000000..3f8f641d04a3
--- /dev/null
+++ b/dev-ml/base_quickcheck/base_quickcheck-0.14.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Randomized testing framework, designed for compatibility with Base"
+HOMEPAGE="https://github.com/janestreet/base_quickcheck"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ >=dev-ml/ppx_base-0.14.0:=
+ >=dev-ml/ppx_fields_conv-0.14.1:=
+ >=dev-ml/ppx_let-0.14.0:=
+ >=dev-ml/ppx_sexp_message-0.14.0:=
+ >=dev-ml/ppx_sexp_value-0.14.0:=
+ dev-ml/splittable_random:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+"
+RDEPEND="${DEPEND}"