summaryrefslogtreecommitdiff
path: root/dev-ml/astring/astring-0.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/astring/astring-0.8.3.ebuild')
-rw-r--r--dev-ml/astring/astring-0.8.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/astring/astring-0.8.3.ebuild b/dev-ml/astring/astring-0.8.3.ebuild
new file mode 100644
index 000000000000..cd17e8514586
--- /dev/null
+++ b/dev-ml/astring/astring-0.8.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit opam
+
+DESCRIPTION="Alternative String module for OCaml"
+HOMEPAGE="http://erratique.ch/software/astring https://github.com/dbuenzli/astring"
+SRC_URI="http://erratique.ch/software/astring/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}