summaryrefslogtreecommitdiff
path: root/dev-ml/alcotest/alcotest-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/alcotest/alcotest-1.6.0.ebuild')
-rw-r--r--dev-ml/alcotest/alcotest-1.6.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/alcotest/alcotest-1.6.0.ebuild b/dev-ml/alcotest/alcotest-1.6.0.ebuild
new file mode 100644
index 000000000000..f1dfe0368ff6
--- /dev/null
+++ b/dev-ml/alcotest/alcotest-1.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A lightweight and colourful test framework"
+HOMEPAGE="https://github.com/mirage/alcotest/"
+SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-ml/dune-2.8:=
+ dev-ml/astring:=
+ dev-ml/async_kernel:=
+ >=dev-ml/async_unix-0.15.0:=
+ dev-ml/base:=
+ dev-ml/cmdliner:=
+ >=dev-ml/core-0.15.0:=
+ >=dev-ml/core_unix-0.15.0:=
+ dev-ml/duration:=
+ >=dev-ml/fmt-0.8.9:=
+ dev-ml/mirage-clock:=
+ dev-ml/re:=
+ dev-ml/result:=
+ dev-ml/logs:=
+ dev-ml/uutf:=
+ dev-ml/uuidm:=
+"
+DEPEND="${RDEPEND}"