summaryrefslogtreecommitdiff
path: root/dev-lua/penlight
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/penlight')
-rw-r--r--dev-lua/penlight/Manifest3
-rw-r--r--dev-lua/penlight/metadata.xml14
-rw-r--r--dev-lua/penlight/penlight-1.3.2.ebuild27
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-lua/penlight/Manifest b/dev-lua/penlight/Manifest
new file mode 100644
index 000000000000..eb7bb3729166
--- /dev/null
+++ b/dev-lua/penlight/Manifest
@@ -0,0 +1,3 @@
+DIST penlight-1.3.2-core.zip 116854 BLAKE2B c653a51cf8ea286c849e1a2c68968ed767c350b1461dd11d9a2e99c81295461c67044175c7bf99c31e8040118e6cfce85f8613d4b6c49e726d31393029abcbbf SHA512 01ba35e967e255f6f39afff9c2238f4921de9e52850ce0d2ec0c9068029fc61a241c82bede680a28fda46c4504582784fcd2241a2eef0bef95c7c389c4042d02
+EBUILD penlight-1.3.2.ebuild 659 BLAKE2B 4de13b932f381af1ecbfcd54bab0f367b58b818e4f38246db383c2ad345b8b2779e777c812aa031b6264e214661ddb24cd4e7cfc2c548d40cf08f25c44745abe SHA512 e3cda7748fe8e59384e598a570516d0e865c58d67ec9856732c3db2bbe55fd81c4cd4decaf12d175d59e2edf216454dc676fdfaa044bc31396751f1340f33b79
+MISC metadata.xml 523 BLAKE2B c9b7340d34bfa27978dfedde2becbb1ea65d911986be0868c76d16796285be730c073da63cd05e46d7ec58af155a09cd6fe635360324a8e252210eb47e3097a7 SHA512 c4a0a69c82dc2dfe49d9f5145847e952f466fd6254baef24f20cd122137071c5731643202bc7bfbb20934ae955454d077fdd74eb30f9d14f67823eec8b089cbc
diff --git a/dev-lua/penlight/metadata.xml b/dev-lua/penlight/metadata.xml
new file mode 100644
index 000000000000..8fc3b6a3bf44
--- /dev/null
+++ b/dev-lua/penlight/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ Penlight is a set of pure Lua libraries for making it easier to work
+ with common tasks like iterating over directories, reading
+ configuration files and the like. Provides functional operations
+ on tables and sequences.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-lua/penlight/penlight-1.3.2.ebuild b/dev-lua/penlight/penlight-1.3.2.ebuild
new file mode 100644
index 000000000000..9f198c77414e
--- /dev/null
+++ b/dev-lua/penlight/penlight-1.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
+HOMEPAGE="http://stevedonovan.github.com/Penlight",
+SRC_URI="http://stevedonovan.github.io/files/${PN}-1.3.2-core.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+app-arch/unzip
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ dev-lua/luafilesystem"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins -r lua/pl
+}