summaryrefslogtreecommitdiff
path: root/dev-lua/penlight/penlight-1.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/penlight/penlight-1.3.2.ebuild')
-rw-r--r--dev-lua/penlight/penlight-1.3.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-lua/penlight/penlight-1.3.2.ebuild b/dev-lua/penlight/penlight-1.3.2.ebuild
new file mode 100644
index 000000000000..07e180c74306
--- /dev/null
+++ b/dev-lua/penlight/penlight-1.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
+HOMEPAGE="http://stevedonovan.github.com/Penlight",
+SRC_URI="http://stevedonovan.github.io/files/${PN}-1.3.2-core.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+app-arch/unzip
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ dev-lua/luafilesystem"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins -r lua/pl
+}