summaryrefslogtreecommitdiff
path: root/dev-lua/luarocks/luarocks-3.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luarocks/luarocks-3.3.1.ebuild')
-rw-r--r--dev-lua/luarocks/luarocks-3.3.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lua/luarocks/luarocks-3.3.1.ebuild b/dev-lua/luarocks/luarocks-3.3.1.ebuild
new file mode 100644
index 000000000000..7607520b4826
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-3.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="libressl"
+
+DEPEND="dev-lang/lua:="
+RDEPEND="${DEPEND}
+ net-misc/curl
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl:0 )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ # econf doesn't work b/c it passes variables the custom configure can't
+ # handle
+ ./configure \
+ --prefix="${EPRIFIX}/usr" \
+ --with-lua-lib="${EPRIFIX}/usr/$(get_libdir)" \
+ --rocks-tree="${EPRIFIX}/usr/$(get_libdir)/lua/luarocks" \
+ || die "configure failed"
+}
+
+src_install() {
+ default
+ { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die "sed failed"
+}