summaryrefslogtreecommitdiff
path: root/dev-lua/lua-term/lua-term-0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lua-term/lua-term-0.7.ebuild')
-rw-r--r--dev-lua/lua-term/lua-term-0.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-lua/lua-term/lua-term-0.7.ebuild b/dev-lua/lua-term/lua-term-0.7.ebuild
new file mode 100644
index 000000000000..e9c4c9e672c7
--- /dev/null
+++ b/dev-lua/lua-term/lua-term-0.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+# Yes, upstream used different version numbers.
+# The rockspec version number is 0.7, but the version associated with
+# the tarball is 0.07.
+MY_PV=0.07
+
+DESCRIPTION="Terminal functions for Lua"
+HOMEPAGE="https://github.com/hoelzro/lua-term"
+SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+ -o core.so core.c"
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+ -o core.so core.c || die
+}
+
+src_install() {
+ exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/term
+ doexe core.so
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins -r term
+}