summaryrefslogtreecommitdiff
path: root/dev-lisp/ecl/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/ecl/files')
-rw-r--r--dev-lisp/ecl/files/README.gentoo13
-rw-r--r--dev-lisp/ecl/files/ecl-16.1.3-build.patch10
-rw-r--r--dev-lisp/ecl/files/ecl-16.1.3-headers-gentoo.patch15
-rw-r--r--dev-lisp/ecl/files/ecl-21.2.1-donotcompressinfo.patch35
-rw-r--r--dev-lisp/ecl/files/ecl-21.2.1-ldflags.patch13
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-lisp/ecl/files/README.gentoo b/dev-lisp/ecl/files/README.gentoo
new file mode 100644
index 000000000000..c95b6cb75167
--- /dev/null
+++ b/dev-lisp/ecl/files/README.gentoo
@@ -0,0 +1,13 @@
+-*- outline -*-
+
+Gentoo GNU/Linux specific notes for ECL
+---------------------------------------
+
+ * The Gentoo port includes a patch to ECL's installed header file (ech.h) so
+ that TRUE and FALSE are not redefined if they're already included from
+ elsewhere. This makes it easier to use ECL with other software which defines
+ those C preprocesser symbols (eg. glib-2.0).
+
+If you encounter any problems or have suggestions, use https://bugs.gentoo.org/.
+Please don't bother the upstream authors unless you are absolutely certain it is
+not Gentoo-related.
diff --git a/dev-lisp/ecl/files/ecl-16.1.3-build.patch b/dev-lisp/ecl/files/ecl-16.1.3-build.patch
new file mode 100644
index 000000000000..ff7d6cd74d8b
--- /dev/null
+++ b/dev-lisp/ecl/files/ecl-16.1.3-build.patch
@@ -0,0 +1,10 @@
+diff -r -U2 ecl-16.1.3.orig/src/c/printer/write_sse.d ecl-16.1.3/src/c/printer/write_sse.d
+--- ecl-16.1.3.orig/src/c/printer/write_sse.d 2016-12-19 17:25:00.000000000 +0700
++++ ecl-16.1.3/src/c/printer/write_sse.d 2016-12-19 19:20:01.863563607 +0700
+@@ -13,4 +13,6 @@
+ */
+
++#include <ecl/config.h>
++
+ #ifdef ECL_SSE2
+ #include <ecl/ecl.h>
diff --git a/dev-lisp/ecl/files/ecl-16.1.3-headers-gentoo.patch b/dev-lisp/ecl/files/ecl-16.1.3-headers-gentoo.patch
new file mode 100644
index 000000000000..10802aa48803
--- /dev/null
+++ b/dev-lisp/ecl/files/ecl-16.1.3-headers-gentoo.patch
@@ -0,0 +1,15 @@
+diff -r -U2 ecl-16.1.3.orig/src/h/object.h ecl-16.1.3/src/h/object.h
+--- ecl-16.1.3.orig/src/h/object.h 2016-12-19 17:25:00.000000000 +0700
++++ ecl-16.1.3/src/h/object.h 2016-12-19 19:22:21.147557750 +0700
+@@ -26,6 +26,11 @@
+ */
+
++#ifndef TRUE
+ #define TRUE 1 /* boolean true value */
++#endif
++
++#ifndef FALSE
+ #define FALSE 0 /* boolean false value */
++#endif
+
+ #if !defined(__cplusplus) && !defined(bool)
diff --git a/dev-lisp/ecl/files/ecl-21.2.1-donotcompressinfo.patch b/dev-lisp/ecl/files/ecl-21.2.1-donotcompressinfo.patch
new file mode 100644
index 000000000000..722e5dc7483f
--- /dev/null
+++ b/dev-lisp/ecl/files/ecl-21.2.1-donotcompressinfo.patch
@@ -0,0 +1,35 @@
+diff --git a/src/doc/Makefile.in b/src/doc/Makefile.in
+index 5660f41..c2aadbe 100644
+--- a/src/doc/Makefile.in
++++ b/src/doc/Makefile.in
+@@ -15,7 +15,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_INFO = @INSTALL_INFO@
+ mkinstalldirs = $(top_srcdir)/bdwgc/install-sh -d
+-INFO_FILE = ecl.info.gz
++INFO_FILE = ecl.info
+ MAKEINFO = @MAKEINFO@
+ MANUAL_MAKE_TARGET = @MANUAL_MAKE_TARGET@
+ MANUAL_INSTALL_TARGET = @MANUAL_INSTALL_TARGET@
+diff --git a/src/doc/manual/Makefile b/src/doc/manual/Makefile
+index f82c287..2ff67e0 100644
+--- a/src/doc/manual/Makefile
++++ b/src/doc/manual/Makefile
+@@ -5,15 +5,14 @@ FILES= *.txi */*.txi figures/*
+ all: pdf info html
+
+ pdf: manual.pdf
+-info: ecl.info.gz
++info: ecl.info
+ html: html/index.html
+
+ manual.pdf: $(FILES)
+ texi2pdf manual.txi
+
+-ecl.info.gz: $(FILES)
++ecl.info: $(FILES)
+ $(MAKEINFO) --no-split manual.txi
+- gzip < ecl.info > ecl.info.gz
+
+ html/index.html: $(FILES)
+ $(MAKEINFO) --html --css-include=ecl.css --split=section manual.txi
diff --git a/dev-lisp/ecl/files/ecl-21.2.1-ldflags.patch b/dev-lisp/ecl/files/ecl-21.2.1-ldflags.patch
new file mode 100644
index 000000000000..5ac4cc5ea793
--- /dev/null
+++ b/dev-lisp/ecl/files/ecl-21.2.1-ldflags.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/723162
+
+--- ecl-21.2.1/src/c/Makefile.in
++++ ecl-21.2.1/src/c/Makefile.in
+@@ -104,7 +104,7 @@
+
+ $(DPP): $(srcdir)/dpp.c $(srcdir)/symbols_list.h
+ if test -f ../CROSS-DPP; then touch dpp; else \
+- $(TRUE_CC) -I$(srcdir) -I@true_builddir@ -I./ $(srcdir)/dpp.c @CPPFLAGS@ @CFLAGS@ @ECL_CFLAGS@ -o $@ ; \
++ $(TRUE_CC) -I$(srcdir) -I@true_builddir@ -I./ $(srcdir)/dpp.c @CPPFLAGS@ @CFLAGS@ @ECL_CFLAGS@ @LDFLAGS@ -o $@ ; \
+ fi
+
+ $(OBJS): $(DPP)