summaryrefslogtreecommitdiff
path: root/dev-lisp/c2ffi/c2ffi-14.0.0.20220729.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/c2ffi/c2ffi-14.0.0.20220729.ebuild')
-rw-r--r--dev-lisp/c2ffi/c2ffi-14.0.0.20220729.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/c2ffi-14.0.0.20220729.ebuild b/dev-lisp/c2ffi/c2ffi-14.0.0.20220729.ebuild
new file mode 100644
index 000000000000..c9b4b403c339
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-14.0.0.20220729.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake llvm
+
+MY_COMMIT="25fcec13381f495460f4a4eafdd1b939c799df4a"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-devel/clang:14
+ sys-devel/llvm:14"
+RDEPEND="${DEPEND}"