summaryrefslogtreecommitdiff
path: root/dev-lisp/c2ffi/c2ffi-12.0.0.20210615.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/c2ffi/c2ffi-12.0.0.20210615.ebuild')
-rw-r--r--dev-lisp/c2ffi/c2ffi-12.0.0.20210615.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/c2ffi-12.0.0.20210615.ebuild b/dev-lisp/c2ffi/c2ffi-12.0.0.20210615.ebuild
new file mode 100644
index 000000000000..49b836463adb
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-12.0.0.20210615.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake llvm
+
+MY_COMMIT="3a92064409d258e1688727266c3f023a502e8866"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-devel/clang:12=
+ sys-devel/llvm:12=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"