summaryrefslogtreecommitdiff
path: root/dev-lisp/abcl/abcl-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/abcl/abcl-1.8.0.ebuild')
-rw-r--r--dev-lisp/abcl/abcl-1.8.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lisp/abcl/abcl-1.8.0.ebuild b/dev-lisp/abcl/abcl-1.8.0.ebuild
new file mode 100644
index 000000000000..139a56a5ef2d
--- /dev/null
+++ b/dev-lisp/abcl/abcl-1.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_P=${PN}-src-${PV}
+
+DESCRIPTION="Armed Bear Common Lisp is a Common Lisp implementation for the JVM."
+HOMEPAGE="http://common-lisp.net/project/armedbear/"
+SRC_URI="http://abcl.org/releases/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2-with-classpath-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8"
+RDEPEND=">=virtual/jre-1.8"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ eant abcl.compile || die "Can't compile ABCL"
+ eant abcl.jar || die "Can't make ABCL jar archive"
+}
+
+src_install() {
+ java-pkg_dojar dist/abcl.jar
+ java-pkg_dolauncher ${PN} --java_args "-server -Xrs" --main org.armedbear.lisp.Main
+ dodoc README
+}