summaryrefslogtreecommitdiff
path: root/dev-libs/zix
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/zix')
-rw-r--r--dev-libs/zix/Manifest2
-rw-r--r--dev-libs/zix/zix-0.6.2.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/zix/Manifest b/dev-libs/zix/Manifest
index 43cb977d0ba9..48f58b3f504c 100644
--- a/dev-libs/zix/Manifest
+++ b/dev-libs/zix/Manifest
@@ -1,3 +1,5 @@
DIST zix-0.4.2.tar.xz 76492 BLAKE2B 46d9e3049632abe8fe60928fa4d27ab5a94e86549dbde999c8215f951fe6f70f29124c89de9639c07a3bfb06da6ce902ea2a59f431ea6015d2c7a38df2f6eff6 SHA512 b8fb931a3e9ab5a67f6da57a07bf10b91e7f861c8cf39db14c49c083a9983a0971cc6bc6abcb54a83c00471b386e377cb9bb51e2edd945ba07b9ae43a35964cc
+DIST zix-0.6.2.tar.xz 81316 BLAKE2B 230d9f6717f10ac6f7608593fa94331a4aebd8c4c1c59f1db5a7d1881d674d687d67c353c3944bf4649ea5cbb49a8c4afe8abc82bad9eaf84bff79777a0a91e1 SHA512 3b072f00481a34e8b900311c2dc77fd73a63a34f69ea953be6b714f5bcbdebcc3cdd81feae73b5ad2bdc09a4bac122e12d9035cfc417ca41dfe5230d1fe13d9c
EBUILD zix-0.4.2.ebuild 1018 BLAKE2B 1c155e1ef4f8f16e0aa8b5f36129a3ae815e3efd2196dcbe0259ffd1fc0f007823d59a6cccebd5049b461ce4da32b707098f28c6be7bf0849598cd6f464ab3fc SHA512 340f5558c6012bfe024b3f286a0cf08d8f8a1adbf3be4f3710145e7e1864da5f5cd9ac562a1b66dbbb16a069d16246793b085f55ae7293025ea134e62883edfb
+EBUILD zix-0.6.2.ebuild 1024 BLAKE2B dd4ae90fb9bbf875e165833701abc1b53bf97093612673410841d26a14518115c0541097b9977f038a19532e474fddc642a3896aa408dfc2a6ddafe8076b8cf5 SHA512 08b4da68f521f50a699ce2759c59e445785b8bc40f919608ccc0744eb7fb96b1abbbfc0a0993a07fbd686d6bf147fa26f2229f53cccc07750372b57c66998ac8
MISC metadata.xml 389 BLAKE2B c95e820b65fd6172f710a0f52e4480f653b7f536af3bc68a7fb04c660d62c22f71809a64e3c744b6ccb3159e4e33746b88f12f4cd0783f6c9ad8dfab1022e9fb SHA512 1053e837fd2181ddbb08c56a71d31b93a59668434f59d415e25a81c1211ff97845724501563d290c64ede01cdae20b54c8931eb7e390c7d9abfbd40d63f6a097
diff --git a/dev-libs/zix/zix-0.6.2.ebuild b/dev-libs/zix/zix-0.6.2.ebuild
new file mode 100644
index 000000000000..fdf378946bdb
--- /dev/null
+++ b/dev-libs/zix/zix-0.6.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="Lightweight C library of portability wrappers and data structures"
+#HOMEPAGE="https://drobilla.net/software/zix.html"
+HOMEPAGE="https://gitlab.com/drobilla/zix"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-text/doxygen
+ dev-python/sphinx
+ dev-python/sphinx-lv2-theme
+ dev-python/sphinxygen
+ )
+"
+
+src_prepare() {
+ default
+
+ # fix doc installation path
+ sed -i "s/versioned_name/'${PF}'/g" doc/html/meson.build doc/singlehtml/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_feature doc docs)
+ $(meson_feature test tests)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ local DOCS=( NEWS README.md )
+ einstalldocs
+}