summaryrefslogtreecommitdiff
path: root/dev-libs/xapian
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/Manifest2
-rw-r--r--dev-libs/xapian/xapian-1.4.26.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index 204880c55259..82b61a229dd9 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -1,3 +1,5 @@
DIST xapian-core-1.4.25.tar.xz 3205904 BLAKE2B 7b03a8fabc3c688f58b3451541dedb664de0a02d7c46a4e8eac080c004232575c00428110eaab0ea463df5c3f43f2b4cebfbe6754f897e55f113683c1db43b2b SHA512 e8069f2cb75554978716a99580fb57fc73bbdd607c82394f53d07205d8c78fb59265004be0c676a6806bb2840a3933499dfc867e36a28855278569a0676d469d
+DIST xapian-core-1.4.26.tar.xz 3246304 BLAKE2B f68b25741de821ef6de2ae5127f09f69a68c435dd224b796d92fc18769db3e3307a0a3aadc98cf26adc966eb063fdbd3ee612ec725020cfc79bdfa041675794b SHA512 ecd94d410dc94b6510c6729f276606987f9dd955cfb0520e62d46fa71645f5b140d474cda0d77078e64ee7cf9c0cd00f3aefe0e1b087739582e64bbcb9fabd4b
EBUILD xapian-1.4.25.ebuild 1553 BLAKE2B 8d0c0220fee94e6c2407237f2c043c9b413e7d1b0e8d82f20f6aeaba5d1fb6890d14d6d2cc45115a42410544c639860494e18eeadb8b76fc3c89c11813c21d89 SHA512 4b5a979658474fdc6a2b4712a65ae0df9d41894ea1161c7638c03ff858308b22aed64b9c5f2a72031cc9e89d465816b0f8c7b81b0c30ebd23ba1e652320d20db
+EBUILD xapian-1.4.26.ebuild 1560 BLAKE2B 222128f8cc9201937117c1df6b805e9e00dd676403509bb6eb6104b83d12b64092d4153ccb36b8f4724019fc20487c8d1c245e3edf9bc5c9b5f6a5461f14d504 SHA512 ede78237f092147fd8676185de39a691130576202e1fb3ac95ed4175ada05bcbd3a88c113428c4001d86a8b0592390169c806d6c86bb1c7975a0bd01e356590c
MISC metadata.xml 583 BLAKE2B 171ba94d14d632c0654d7a7035c1a2ea8b02e7c2ed43b37cae25d8af91f90341cb4dc3cc7982b270bde8667f085eef568236a53d34add2127bbdaee668af4dcb SHA512 cc7bfffe1db364b1ddb9859ae27a2775ef57498d8668470c0b719579d5d8656f8eb1b5a0288e938f80b88b42489aa7e3dbea282140b5a7143f8ff106efb60274
diff --git a/dev-libs/xapian/xapian-1.4.26.ebuild b/dev-libs/xapian/xapian-1.4.26.ebuild
new file mode 100644
index 000000000000..25f4dd84a037
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.26.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P="${PN}-core-${PV}"
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="https://xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
+IUSE="cpu_flags_x86_sse cpu_flags_x86_sse2 debug static-libs"
+
+DEPEND="
+ sys-libs/zlib:=
+ !elibc_Darwin? ( !elibc_SunOS? ( sys-apps/util-linux ) )
+ elibc_SunOS? ( sys-libs/libuuid )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS HACKING PLATFORMS README NEWS )
+
+src_configure() {
+ tc-export_build_env BUILD_CC
+ local -x CC_FOR_BUILD="${BUILD_CC}"
+
+ # skip certain autoconf checks
+ local -x VALGRIND=
+ local -x EATMYDATA=
+
+ local -a myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ --disable-werror
+ --enable-backend-chert
+ --enable-backend-glass
+ --enable-backend-inmemory
+ --enable-backend-remote
+ --program-suffix=
+ $(use_enable debug assertions)
+ $(use_enable debug log)
+ $(use_enable static-libs static)
+ )
+
+ if use cpu_flags_x86_sse2; then
+ myconf+=( --enable-sse=sse2 )
+ elif use cpu_flags_x86_sse; then
+ myconf+=( --enable-sse=sse )
+ else
+ myconf+=( --disable-sse )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake -Onone check
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -type f -delete || die
+}