summaryrefslogtreecommitdiff
path: root/dev-libs/xapian/xapian-1.2.25-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xapian/xapian-1.2.25-r1.ebuild')
-rw-r--r--dev-libs/xapian/xapian-1.2.25-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/xapian/xapian-1.2.25-r1.ebuild b/dev-libs/xapian/xapian-1.2.25-r1.ebuild
new file mode 100644
index 000000000000..8dc1dcb06fb8
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.2.25-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="https://www.xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/1.2.22" # ABI version of libxapian.so, prefixed with 1.2.
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sparc x86 ~x64-solaris"
+IUSE="doc static-libs cpu_flags_x86_sse cpu_flags_x86_sse2 +brass +chert +inmemory"
+
+DEPEND="sys-apps/util-linux[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ # "brass_check.cc:40:48: error: reference to ‘byte’ is ambiguous"
+ # bug #789390
+ append-cxxflags -std=c++14
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-flint --enable-backend-remote"
+
+ ECONF_SOURCE=${S} econf ${myconf}
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ use doc || rm -rf "${ED%/}/usr/share/doc/xapian-core-${PV}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ find "${ED}" -name "*.la" -type f -delete || die
+}
+
+multilib_src_test() {
+ emake check VALGRIND=
+}