summaryrefslogtreecommitdiff
path: root/dev-libs/wayland
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/Manifest3
-rw-r--r--dev-libs/wayland/files/wayland-1.23.0-c23-clang-fix.patch146
-rw-r--r--dev-libs/wayland/wayland-1.23.0-r1.ebuild70
3 files changed, 0 insertions, 219 deletions
diff --git a/dev-libs/wayland/Manifest b/dev-libs/wayland/Manifest
index 9d6193458a45..d3d8673aa979 100644
--- a/dev-libs/wayland/Manifest
+++ b/dev-libs/wayland/Manifest
@@ -1,7 +1,4 @@
-AUX wayland-1.23.0-c23-clang-fix.patch 4740 BLAKE2B fceae0f54e0d12c8c7651641294cfb4d106e56bc3d1e4c8766bda5e9f22e811b22e207bc32c85c9336787a19d70e3d66d991b4fb201acbcb378a68b80c2dca5a SHA512 9dea2ce6b5a8ce430fa7c2302c2f2abbf2119056eec8caaf10efee6b3d5fdb9a7da3351868eddb013786efca95fa26cfc68aa77ef42a00843c2922dc0d924386
-DIST wayland-1.23.0.tar.xz 237900 BLAKE2B efb80e3c67db7a707a6d2ea66e7a5132173550bc13fdff447925ec3d33bfba8131532f819d5ab0dd80924cb4339b58b7ca83d9e70a436cea8268167476355bd8 SHA512 9c525231a7ea3e68d3178230d476285a960d23e38571ac96d885f86c0588c52ef01460bff6833db5adb9456ce8db7b996613611187aac972736748ba91b8fd81
DIST wayland-1.23.1.tar.xz 238212 BLAKE2B 74784b537a6e28610466ff1549286cea9ff8b9ca914afa26a07f177bbe0be56b80de037d5eb5d07a38bf02a9041c32e62c896facd5417c1435571640ad8f87b2 SHA512 818eda003e3f7aa15690eedb1ff227a6056b2ce54bf23d45ffe573dc40a914623c5a1358218b59444dcdc483db0503324f0d27091d0ea954412a8b290de5f50a
-EBUILD wayland-1.23.0-r1.ebuild 1726 BLAKE2B 09dffc214c8508a5e1716ec52e4363e6f01161b815ecee4875679b8033d06673e49f924c7825776e0115720f52bb5c8d8f551374cf6a9d94191baa0ca085bf8f SHA512 cff83dee704836c7968ee6e66b6037f6a8f4a5f29c00f8bb69fbeb1370fe7db20c46430a7604fa2d232b43a1db6f522841947fda435672a6f40de031f1ffbeea
EBUILD wayland-1.23.1.ebuild 1663 BLAKE2B c37191ddaffd76d0c0b7f7edf16c9212591d00acf9f628e9f6154ba635f2228c527f41c20fd2109da38790f257043dfc93c09e2e0f8126b9061a08f1984e402a SHA512 7948d5eaf9277783da2c8390c8baa8cca0d47510f49965c18cc392540a63cbe7342b3a12617451bcf597f616400ddafa7d6da2e5ff95495cc3550c9109a78d4c
EBUILD wayland-9999.ebuild 1670 BLAKE2B edbf9bd6fb9d9bc4a89e9440f5fea6bf945616f8adc08a95cfa2534fd8ef64f9bfed730ba3389af91be45294ee8783a478278534de8be2e42b54cfd1f9782d8d SHA512 a2cd4fe74a60111362a1e949924f195a260302b74142bcec021bff56fd16ea479454d1c1e836c0fd874b504e4d527855ddc52dfa7ac6678adb7004187fd653e2
MISC metadata.xml 337 BLAKE2B af249efc25c3eadde73d0b49cba0e6c8a021fb4b7c9a0b96f27a4e71185c76f8ac7ff0b9efdfeadf2df324cfa578db3a73fc7bee8c249cba35d41e2145017e16 SHA512 771b226f8e16d8c570bc2ea89ee3c5176e1d0f2209afb3b2af5a9d19fbdc2037a411b84d546bea054449c8074fb0fb3c3726fb2692d084521c64cda60600c0b8
diff --git a/dev-libs/wayland/files/wayland-1.23.0-c23-clang-fix.patch b/dev-libs/wayland/files/wayland-1.23.0-c23-clang-fix.patch
deleted file mode 100644
index 8dc80d3c8fe8..000000000000
--- a/dev-libs/wayland/files/wayland-1.23.0-c23-clang-fix.patch
+++ /dev/null
@@ -1,146 +0,0 @@
-https://bugs.gentoo.org/936061
-https://gitlab.freedesktop.org/wlroots/wlroots/-/issues/3859
-https://gitlab.freedesktop.org/wayland/wayland/-/merge_requests/401
-
-From 7be937e795ff88128d64b88f9482f05aa0d91319 Mon Sep 17 00:00:00 2001
-From: Kirill Primak <vyivel@eclair.cafe>
-Date: Sat, 29 Jun 2024 15:05:00 +0300
-Subject: [PATCH] Put WL_DEPRECATED in front of the function declarations
-
-This fixes the following clang error when using C23:
-
-../src/wayland-server-core.h:680:41: error: 'deprecated' attribute cannot be applied to types
- 680 | int32_t stride, uint32_t format) WL_DEPRECATED;
- | ^
-../src/wayland-util.h:52:25: note: expanded from macro 'WL_DEPRECATED'
- 52 | #define WL_DEPRECATED [[deprecated]]
- | ^
-
-Signed-off-by: Kirill Primak <vyivel@eclair.cafe>
---- a/src/wayland-server-core.h
-+++ b/src/wayland-server-core.h
-@@ -674,10 +674,11 @@ wl_display_init_shm(struct wl_display *display);
- uint32_t *
- wl_display_add_shm_format(struct wl_display *display, uint32_t format);
-
-+WL_DEPRECATED
- struct wl_shm_buffer *
- wl_shm_buffer_create(struct wl_client *client,
- uint32_t id, int32_t width, int32_t height,
-- int32_t stride, uint32_t format) WL_DEPRECATED;
-+ int32_t stride, uint32_t format);
-
- void
- wl_log_set_handler_server(wl_log_func_t handler);
---- a/src/wayland-server.c
-+++ b/src/wayland-server.c
-@@ -2483,9 +2483,10 @@ wl_priv_signal_final_emit(struct wl_priv_signal *signal, void *data)
-
- /** \cond */ /* Deprecated functions below. */
-
-+WL_DEPRECATED
- uint32_t
- wl_client_add_resource(struct wl_client *client,
-- struct wl_resource *resource) WL_DEPRECATED;
-+ struct wl_resource *resource);
-
- WL_EXPORT uint32_t
- wl_client_add_resource(struct wl_client *client,
-@@ -2514,11 +2515,12 @@ wl_client_add_resource(struct wl_client *client,
- return resource->object.id;
- }
-
-+WL_DEPRECATED
- struct wl_resource *
- wl_client_add_object(struct wl_client *client,
- const struct wl_interface *interface,
- const void *implementation,
-- uint32_t id, void *data) WL_DEPRECATED;
-+ uint32_t id, void *data);
-
- WL_EXPORT struct wl_resource *
- wl_client_add_object(struct wl_client *client,
-@@ -2537,10 +2539,11 @@ wl_client_add_object(struct wl_client *client,
- return resource;
- }
-
-+WL_DEPRECATED
- struct wl_resource *
- wl_client_new_object(struct wl_client *client,
- const struct wl_interface *interface,
-- const void *implementation, void *data) WL_DEPRECATED;
-+ const void *implementation, void *data);
-
- WL_EXPORT struct wl_resource *
- wl_client_new_object(struct wl_client *client,
-@@ -2599,10 +2602,11 @@ wl_client_get_user_data(struct wl_client *client)
- return client->data;
- }
-
-+WL_DEPRECATED
- struct wl_global *
- wl_display_add_global(struct wl_display *display,
- const struct wl_interface *interface,
-- void *data, wl_global_bind_func_t bind) WL_DEPRECATED;
-+ void *data, wl_global_bind_func_t bind);
-
- WL_EXPORT struct wl_global *
- wl_display_add_global(struct wl_display *display,
-@@ -2612,9 +2616,10 @@ wl_display_add_global(struct wl_display *display,
- return wl_global_create(display, interface, interface->version, data, bind);
- }
-
-+WL_DEPRECATED
- void
- wl_display_remove_global(struct wl_display *display,
-- struct wl_global *global) WL_DEPRECATED;
-+ struct wl_global *global);
-
- WL_EXPORT void
- wl_display_remove_global(struct wl_display *display, struct wl_global *global)
---- a/src/wayland-server.h
-+++ b/src/wayland-server.h
-@@ -70,30 +70,35 @@ struct wl_resource {
- void *data;
- };
-
-+WL_DEPRECATED
- uint32_t
- wl_client_add_resource(struct wl_client *client,
-- struct wl_resource *resource) WL_DEPRECATED;
-+ struct wl_resource *resource);
-
-+WL_DEPRECATED
- struct wl_resource *
- wl_client_add_object(struct wl_client *client,
- const struct wl_interface *interface,
- const void *implementation,
-- uint32_t id, void *data) WL_DEPRECATED;
-+ uint32_t id, void *data);
-
-+WL_DEPRECATED
- struct wl_resource *
- wl_client_new_object(struct wl_client *client,
- const struct wl_interface *interface,
-- const void *implementation, void *data) WL_DEPRECATED;
-+ const void *implementation, void *data);
-
-+WL_DEPRECATED
- struct wl_global *
- wl_display_add_global(struct wl_display *display,
- const struct wl_interface *interface,
- void *data,
-- wl_global_bind_func_t bind) WL_DEPRECATED;
-+ wl_global_bind_func_t bind);
-
-+WL_DEPRECATED
- void
- wl_display_remove_global(struct wl_display *display,
-- struct wl_global *global) WL_DEPRECATED;
-+ struct wl_global *global);
-
- #endif
-
---
-GitLab
-
diff --git a/dev-libs/wayland/wayland-1.23.0-r1.ebuild b/dev-libs/wayland/wayland-1.23.0-r1.ebuild
deleted file mode 100644
index d3a90d11bb3b..000000000000
--- a/dev-libs/wayland/wayland-1.23.0-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
- inherit git-r3
-else
- SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-inherit meson-multilib
-
-DESCRIPTION="Wayland protocol libraries"
-HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- ~dev-util/wayland-scanner-${PV}
- virtual/pkgconfig
- doc? (
- >=app-text/doxygen-1.6[dot]
- app-text/xmlto
- >=media-gfx/graphviz-2.26.0
- )
-"
-DEPEND="
- >=dev-libs/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/wayland-1.23.0-c23-clang-fix.patch
-)
-
-multilib_src_configure() {
- local emesonargs=(
- $(meson_native_use_bool doc documentation)
- $(meson_native_true dtd_validation)
- -Dlibraries=true
- -Dscanner=false
- $(meson_use test tests)
- )
- meson_src_configure
-}
-
-src_test() {
- # We set it on purpose to only a short subdir name, as socket paths are
- # created in there, which are 108 byte limited. With this it hopefully
- # barely fits to the limit with /var/tmp/portage/${CATEGORY}/${PF}/temp/x
- export XDG_RUNTIME_DIR="${T}"/x
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
- multilib-minimal_src_test
-}
-
-src_install() {
- meson-multilib_src_install
-
- if use doc; then
- mv "${ED}"/usr/share/doc/"${PN}"/* "${ED}"/usr/share/doc/"${PF}"/ || die
- rmdir "${ED}"/usr/share/doc/"${PN}" || die
- fi
-}