summaryrefslogtreecommitdiff
path: root/dev-libs/tree-sitter-cpp/tree-sitter-cpp-0.20.0_p20230410.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/tree-sitter-cpp/tree-sitter-cpp-0.20.0_p20230410.ebuild')
-rw-r--r--dev-libs/tree-sitter-cpp/tree-sitter-cpp-0.20.0_p20230410.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/tree-sitter-cpp/tree-sitter-cpp-0.20.0_p20230410.ebuild b/dev-libs/tree-sitter-cpp/tree-sitter-cpp-0.20.0_p20230410.ebuild
new file mode 100644
index 000000000000..c2c06c5b681a
--- /dev/null
+++ b/dev-libs/tree-sitter-cpp/tree-sitter-cpp-0.20.0_p20230410.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit tree-sitter-grammar
+
+# Upstream has not created a release in a while, and there have been
+# some changes that fix weirdness with Emacs tree-sitter-mode.
+GIT_COMMIT="0b6d0eb9abdf7cea31961cd903eeed5bbd0aae74"
+
+DESCRIPTION="C++ grammar for Tree-sitter"
+HOMEPAGE="https://github.com/tree-sitter/tree-sitter-cpp"
+SRC_URI="https://github.com/tree-sitter/${PN}/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${GIT_COMMIT}/src
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# requires test data from tree-sitter-c
+RESTRICT="test"