summaryrefslogtreecommitdiff
path: root/dev-libs/tre
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/tre')
-rw-r--r--dev-libs/tre/Manifest2
-rw-r--r--dev-libs/tre/files/0.8.0-CVE-2016-8559.patch73
-rw-r--r--dev-libs/tre/tre-0.8.0-r2.ebuild67
3 files changed, 142 insertions, 0 deletions
diff --git a/dev-libs/tre/Manifest b/dev-libs/tre/Manifest
index b202c4251c28..775dee76b642 100644
--- a/dev-libs/tre/Manifest
+++ b/dev-libs/tre/Manifest
@@ -1,4 +1,6 @@
+AUX 0.8.0-CVE-2016-8559.patch 2658 BLAKE2B 12a7d12d35e2d61457fbb9e368cfa738bad74ac490ce4ffa59d1494d879d9db481b89b0e3ef3a2a4601b8280ff8f1c54f4ccdc00716a904bff291923c4aaa02c SHA512 9f45299ccd21cc4e78946ad22963d4505e9cd430f49f275fbb742696029530e7e6eb848b0ae4bf55bb5e2a2ee77d3cf272b02e2a6a2ba7c3bd69f68816e300b2
AUX 0.8.0-pkgcfg.patch 420 BLAKE2B 6b04ff4db2abc5dffdbca50bcbbe20974fdaa24ab25875f2538eca5af42921a729550e7ea5188225d3d73661e9ba05b96ff345fb4d931130ba4255b14c3944d2 SHA512 a6e4713aa0f9619abe256e9e1ea7c5bc8cbeb9ed173dd856972af70612ac435206e2b294ca5947e93223c17de875ba2620bf57949332b19ecff9965e2ee1a9e6
DIST tre-0.8.0.tar.bz2 380714 BLAKE2B b2af6e805e9e19fd69debf2f881ddfb591317f69db4e29a04e1899eb69100b8ac7744f86fa438530509ca2ee8aa1d346d416c6391f13247cd9398f4c59c2ed85 SHA512 db7465993e0d25eee8e52f974427b8a040234cf0f017769eb94ee88bc6261821336aad7f762bfa82db7e2212d8449bc221592586f061c528a59a550773cbc263
EBUILD tre-0.8.0-r1.ebuild 1412 BLAKE2B 5910c54dd847e5ced32abba2c747abcb86c73701332650aa2d937b5470a78bc00be5eaed6cfeb63346b0af0cac702a7baea357ed2dd53aa2c2d600501991fcaa SHA512 ecc2906825000bab1e1286282e445f3da63d36b8896086ba5212646c727300a0c133edfb04a221385b0dc3173156029993aa63f26b43c69d79f78a0ef3aa8d2e
+EBUILD tre-0.8.0-r2.ebuild 1461 BLAKE2B c7ad1e4d468f399e2c3ceb5f40300b4017c4a5ad5489df119ea4bf013264efb22109924ee87466fbd25e2255c39673acc137d0220484c11a67eedc355e8f3ff6 SHA512 4ad4916efd418f0c15427e9571625d2b934cefb2360768b30548787ea29b2df37a414c4599523eccb167203f7fcfafb3e2d3ec75855abd70706e2dfeb0445724
MISC metadata.xml 353 BLAKE2B 0346462595f8f9a38758ce0817e787b87b35b329aef65d2921214d32bd9313023f006ee2ab31084a03a2f8a8ecf1d556dd11f190ac2467ebcd061bc144b977e4 SHA512 907b341e747fb9d7ba7b76f300d373284a21a59e3d649275c4a53ac681177f94e9d0d9f56b15365008262b2aba91236d9ac5623387313c7b74b65b2b70871d3b
diff --git a/dev-libs/tre/files/0.8.0-CVE-2016-8559.patch b/dev-libs/tre/files/0.8.0-CVE-2016-8559.patch
new file mode 100644
index 000000000000..39ceae016446
--- /dev/null
+++ b/dev-libs/tre/files/0.8.0-CVE-2016-8559.patch
@@ -0,0 +1,73 @@
+From c3edc06d1e1360f3570db9155d6b318ae0d0f0f7 Mon Sep 17 00:00:00 2001
+From: Rich Felker <dalias@aerifal.cx>
+Date: Thu, 6 Oct 2016 18:34:58 -0400
+Subject: fix missing integer overflow checks in regexec buffer size
+ computations
+
+most of the possible overflows were already ruled out in practice by
+regcomp having already succeeded performing larger allocations.
+however at least the num_states*num_tags multiplication can clearly
+overflow in practice. for safety, check them all, and use the proper
+type, size_t, rather than int.
+
+also improve comments, use calloc in place of malloc+memset, and
+remove bogus casts.
+---
+ src/regex/regexec.c | 23 ++++++++++++++++++-----
+ 1 file changed, 18 insertions(+), 5 deletions(-)
+
+Note: patch was modified to apply to tre, parts were taken from
+https://github.com/laurikari/tre/issues/37
+
+--- a/lib/tre-match-parallel.c
++++ b/lib/tre-match-parallel.c
+@@ -59,6 +59,7 @@
+ #ifdef HAVE_MALLOC_H
+ #include <malloc.h>
+ #endif /* HAVE_MALLOC_H */
++#include <stdint.h>
+
+ #include "tre-internal.h"
+ #include "tre-match-utils.h"
+@@ -150,11 +151,24 @@
+
+ /* Allocate memory for temporary data required for matching. This needs to
+ be done for every matching operation to be thread safe. This allocates
+- everything in a single large block from the stack frame using alloca()
+- or with malloc() if alloca is unavailable. */
++ everything in a single large block with calloc(). */
+ {
+- int tbytes, rbytes, pbytes, xbytes, total_bytes;
++ size_t tbytes, rbytes, pbytes, xbytes, total_bytes;
+ char *tmp_buf;
++
++ /* Ensure that tbytes and xbytes*num_states cannot overflow, and that
++ * they don't contribute more than 1/8 of SIZE_MAX to total_bytes. */
++ if (num_tags > SIZE_MAX/(8 * sizeof(int) * tnfa->num_states))
++ return REG_BADPAT;
++
++ /* Likewise check rbytes. */
++ if (tnfa->num_states+1 > SIZE_MAX/(8 * sizeof(*reach_next)))
++ return REG_BADPAT;
++
++ /* Likewise check pbytes. */
++ if (tnfa->num_states > SIZE_MAX/(8 * sizeof(*reach_pos)))
++ return REG_BADPAT;
++
+ /* Compute the length of the block we need. */
+ tbytes = sizeof(*tmp_tags) * num_tags;
+ rbytes = sizeof(*reach_next) * (tnfa->num_states + 1);
+@@ -168,11 +182,11 @@
+ #ifdef TRE_USE_ALLOCA
+ buf = alloca(total_bytes);
+ #else /* !TRE_USE_ALLOCA */
+- buf = xmalloc((unsigned)total_bytes);
++ buf = xmalloc(total_bytes);
+ #endif /* !TRE_USE_ALLOCA */
+ if (buf == NULL)
+ return REG_ESPACE;
+- memset(buf, 0, (size_t)total_bytes);
++ memset(buf, 0, total_bytes);
+
+ /* Get the various pointers within tmp_buf (properly aligned). */
+ tmp_tags = (void *)buf;
diff --git a/dev-libs/tre/tre-0.8.0-r2.ebuild b/dev-libs/tre/tre-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..3b7cb484bc4f
--- /dev/null
+++ b/dev-libs/tre/tre-0.8.0-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="Lightweight, robust, and efficient POSIX compliant regexp matching library"
+HOMEPAGE="https://laurikari.net/tre/ https://github.com/laurikari/tre/"
+SRC_URI="https://laurikari.net/tre/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="nls static-libs"
+
+RDEPEND="
+ !app-text/agrep
+ !dev-ruby/amatch
+ !app-misc/glimpse"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-pkgcfg.patch"
+ "${FILESDIR}/${PV}-CVE-2016-8559.patch"
+)
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ econf \
+ --enable-agrep \
+ --enable-system-abi \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ if locale -a | grep -iq en_US.iso88591; then
+ emake -j1 check
+ else
+ ewarn "If you like to run the test,"
+ ewarn "please make sure en_US.ISO-8859-1 is installed."
+ die "en_US.ISO-8859-1 locale is missing"
+ fi
+}
+
+src_install() {
+ local HTML_DOCS=( doc/*.{css,html} )
+
+ default
+
+ # 626480
+ mv "${ED%/}"/usr/bin/agrep{,-tre}$(get_exeext) || die
+}
+
+pkg_postinst() {
+ ewarn "app-misc/glimpse, app-text/agrep and this package all provide agrep."
+ ewarn "If this causes any unforeseen incompatibilities please file a bug"
+ ewarn "on https://bugs.gentoo.org."
+}