summaryrefslogtreecommitdiff
path: root/dev-libs/tinyxml2/tinyxml2-9.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/tinyxml2/tinyxml2-9.0.0-r1.ebuild')
-rw-r--r--dev-libs/tinyxml2/tinyxml2-9.0.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/tinyxml2-9.0.0-r1.ebuild b/dev-libs/tinyxml2/tinyxml2-9.0.0-r1.ebuild
new file mode 100644
index 000000000000..77637717145c
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-9.0.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/9"
+KEYWORDS="amd64 arm arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv sparc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}