summaryrefslogtreecommitdiff
path: root/dev-libs/template-glib/template-glib-3.34.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/template-glib/template-glib-3.34.1.ebuild')
-rw-r--r--dev-libs/template-glib/template-glib-3.34.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-libs/template-glib/template-glib-3.34.1.ebuild b/dev-libs/template-glib/template-glib-3.34.1.ebuild
deleted file mode 100644
index af4f286dc6d7..000000000000
--- a/dev-libs/template-glib/template-glib-3.34.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gnome.org meson vala
-
-DESCRIPTION="Templating library for GLib"
-HOMEPAGE="https://gitlab.gnome.org/GNOME/template-glib"
-
-LICENSE="LGPL-2.1+"
-SLOT="0/1"
-KEYWORDS="amd64 x86"
-
-IUSE="gtk-doc +introspection vala"
-REQUIRED_USE="vala? ( introspection )"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/gobject-introspection:=
-" # depends on go-i unconditionally for own functionality, USE flag controls GIR/typelib generation
-DEPEND="${RDEPEND}"
-BDEPEND="
- vala? ( $(vala_depend) )
- dev-util/glib-utils
- sys-devel/bison
- sys-devel/flex
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
- gtk-doc? ( dev-util/gtk-doc )
-"
-
-src_prepare() {
- default
- use vala && vala_setup
-}
-
-src_configure() {
- local emesonargs=(
- -Denable_tracing=false # extra trace debugging that would make things slower
- -Denable_profiling=false # -pg passing
- $(meson_use introspection with_introspection)
- $(meson_use vala with_vapi)
- $(meson_use gtk-doc enable_gtk_doc)
- )
- meson_src_configure
-}