summaryrefslogtreecommitdiff
path: root/dev-libs/syncdir
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/syncdir')
-rw-r--r--dev-libs/syncdir/Manifest3
-rw-r--r--dev-libs/syncdir/syncdir-1.0-r1.ebuild6
-rw-r--r--dev-libs/syncdir/syncdir-1.0-r2.ebuild40
3 files changed, 45 insertions, 4 deletions
diff --git a/dev-libs/syncdir/Manifest b/dev-libs/syncdir/Manifest
index 71d099adf18f..f4d71663f160 100644
--- a/dev-libs/syncdir/Manifest
+++ b/dev-libs/syncdir/Manifest
@@ -1,3 +1,4 @@
DIST syncdir-1.0.tar.gz 8878 BLAKE2B b9b53d90cb9122e86d23ca8e86ceb4178e4a62e2bdf486e6d7861065592adbc047226581e9d574092590db0a54bf2dd9afbc21e4997ceea3cebb2d66927297b7 SHA512 0b5262e23e43f34be7bc31ed6baf7624a115a509e459504651b184a0856c7918671db4be1b8e14552f275c49c5c6bbc00d786c57f1d96548a491048674f58317
-EBUILD syncdir-1.0-r1.ebuild 834 BLAKE2B 6c46acb954b7f8f666ba3f3148147732e7b88d09632b4a30a375fa0455f056e4cab1cc1ba751ccf93357e99735946910e3d0ccfa54e4110f864321d34cd91e74 SHA512 e263fa1e71a4519edf3c5312911707c4aeb09d7026063a563a744d2fc961cbafa0f167592ba785e2df33f2292897f435f4cf3f86aed9dcf685869f45621b2894
+EBUILD syncdir-1.0-r1.ebuild 836 BLAKE2B e66d5f243775945f49c8ec7386dcad5d59bf06ba8ed3e82c4230cfde4eed4496326cb4d18212451661fe112683654c1e00de386863131f13d9411d065428eb6a SHA512 8339a1611f7fc3d199058672a531bf622e06771f0fe78ef67c16535f6d198d2eb4668db0874167421fbc38f5642ff95111ca2e446765d7b2dbda0420436994cc
+EBUILD syncdir-1.0-r2.ebuild 837 BLAKE2B 91f611dc7bb60af583943f4af6dd315f9cf3a6daeec8b3411b60a630eb5c0a7859dff8b699a1518009ca01c3385c289f92f125f42a416e5ae520c8c72d123418 SHA512 64cbb87b40af76340ec261ad06bb227841b72c4fd8bd46792ffa23f59dd9d2f4e528b34666141837e9463d1789e6d6390d324eb080a3402cbd457df55019666b
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/dev-libs/syncdir/syncdir-1.0-r1.ebuild b/dev-libs/syncdir/syncdir-1.0-r1.ebuild
index 493e2e498c01..7627f5ebe419 100644
--- a/dev-libs/syncdir/syncdir-1.0-r1.ebuild
+++ b/dev-libs/syncdir/syncdir-1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -6,8 +6,8 @@ EAPI=4
inherit multilib toolchain-funcs
DESCRIPTION="Provides an alternate implementation for open, link, rename, and unlink"
-HOMEPAGE="http://untroubled.org/syncdir"
-SRC_URI="http://untroubled.org/syncdir/${P}.tar.gz"
+HOMEPAGE="https://untroubled.org/syncdir"
+SRC_URI="https://untroubled.org/syncdir/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
diff --git a/dev-libs/syncdir/syncdir-1.0-r2.ebuild b/dev-libs/syncdir/syncdir-1.0-r2.ebuild
new file mode 100644
index 000000000000..ed06d5f79598
--- /dev/null
+++ b/dev-libs/syncdir/syncdir-1.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Provides an alternate implementation for open, link, rename, and unlink"
+HOMEPAGE="https://untroubled.org/syncdir"
+SRC_URI="https://untroubled.org/syncdir/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ if ! use static-libs; then
+ sed -i Makefile \
+ -e '/^all:/s|libsyncdir.a||' \
+ -e '/install -m 644 libsyncdir.a/d' \
+ || die "sed Makefile"
+ fi
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ libsyncdir.so \
+ $(use static-libs && echo libsyncdir.a)
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)
+ emake libdir="${D}/usr/$(get_libdir)" install
+ dodoc testsync.c
+}