summaryrefslogtreecommitdiff
path: root/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
index c1f5f5a3a07b..2be1fb23feb6 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,6 +33,8 @@ DEPEND="${COMMON_DEPEND}
BDEPEND="app-editors/vim-core"
# vim-core is needed for "xxd"
+PATCHES=( "${FILESDIR}"/${PN}-4.3.0_no-sqlprofiler.patch )
+
src_prepare() {
# ... otherwise system llvm/clang is used ...
sed -e "s:find_package(Clang REQUIRED HINTS \${CMAKE_INSTALL_PREFIX}/llvm \${CMAKE_PREFIX_PATH}/llvm PATHS /opt/rocm/llvm ):find_package(Clang REQUIRED HINTS ${EPREFIX}/usr/lib/llvm/roc ):" -i image/blit_src/CMakeLists.txt || die