summaryrefslogtreecommitdiff
path: root/dev-libs/rocr-runtime/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rocr-runtime/files')
-rw-r--r--dev-libs/rocr-runtime/files/rocr-runtime-4.3.0_no-sqlprofiler.patch29
-rw-r--r--dev-libs/rocr-runtime/files/rocr-runtime-4.5.2-cmake-install-paths.patch40
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-4.3.0_no-sqlprofiler.patch b/dev-libs/rocr-runtime/files/rocr-runtime-4.3.0_no-sqlprofiler.patch
new file mode 100644
index 000000000000..fdb34b75b2d2
--- /dev/null
+++ b/dev-libs/rocr-runtime/files/rocr-runtime-4.3.0_no-sqlprofiler.patch
@@ -0,0 +1,29 @@
+Index: ROCR-Runtime-rocm-4.3.0/src/core/runtime/amd_gpu_agent.cpp
+===================================================================
+--- src/core/runtime/amd_gpu_agent.cpp
++++ src/core/runtime/amd_gpu_agent.cpp
+@@ -861,11 +861,6 @@ hsa_status_t GpuAgent::GetInfo(hsa_agent
+ setFlag(HSA_EXTENSION_IMAGES);
+ }
+
+- if (os::LibHandle lib = os::LoadLib(kAqlProfileLib)) {
+- os::CloseLib(lib);
+- setFlag(HSA_EXTENSION_AMD_AQLPROFILE);
+- }
+-
+ setFlag(HSA_EXTENSION_AMD_PROFILER);
+
+ break;
+Index: ROCR-Runtime-rocm-4.3.0/src/core/runtime/hsa.cpp
+===================================================================
+--- src/core/runtime/hsa.cpp
++++ src/core/runtime/hsa.cpp
+@@ -471,7 +471,7 @@ hsa_status_t hsa_system_get_major_extens
+ return HSA_STATUS_SUCCESS;
+ }
+
+- if (extension == HSA_EXTENSION_AMD_AQLPROFILE) {
++ if (0) {
+ if (version_major != hsa_ven_amd_aqlprofile_VERSION_MAJOR) {
+ debug_print("aqlprofile API incompatible ver %d, current ver %d\n",
+ version_major, hsa_ven_amd_aqlprofile_VERSION_MAJOR);
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-4.5.2-cmake-install-paths.patch b/dev-libs/rocr-runtime/files/rocr-runtime-4.5.2-cmake-install-paths.patch
new file mode 100644
index 000000000000..063fafe336f7
--- /dev/null
+++ b/dev-libs/rocr-runtime/files/rocr-runtime-4.5.2-cmake-install-paths.patch
@@ -0,0 +1,40 @@
+--- a/CMakeLists.txt 2021-12-10 22:55:24.000000000 +0100
++++ b/CMakeLists.txt 2021-12-15 15:33:43.545084656 +0100
+@@ -286,35 +286,17 @@
+ install ( TARGETS ${CORE_RUNTIME_NAME} EXPORT ${CORE_RUNTIME_NAME}Targets )
+ endif()
+
+-## Create symlinks for legacy packaging and install
+-add_custom_target ( hsa_include_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../include/hsa hsa_include_link )
+-if ( ${BUILD_SHARED_LIBS} )
+- add_custom_target ( hsa_lib_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../lib/${CORE_RUNTIME_LIBRARY}.so ${CORE_RUNTIME_LIBRARY}-link.so )
+- add_custom_target ( hsa_lib_link2 ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../lib/${CORE_RUNTIME_LIBRARY}.so.${VERSION_MAJOR} ${CORE_RUNTIME_LIBRARY}-link.so.${VERSION_MAJOR} )
+-endif()
+-
+ ## Set install information
+ # Installs binaries and exports the library usage data to ${HSAKMT_TARGET}Targets
+ # TODO: Fix me for flat directory layout. Should be ${CMAKE_INSTALL_LIBDIR}
+-install ( TARGETS ${CORE_RUNTIME_TARGET} EXPORT ${CORE_RUNTIME_NAME}Targets
+- ARCHIVE DESTINATION lib COMPONENT binary
+- LIBRARY DESTINATION lib COMPONENT binary )
++install ( TARGETS ${CORE_RUNTIME_TARGET} EXPORT ${CORE_RUNTIME_NAME}Targets LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} )
+
+ # Install license
+ #install ( FILES ${CMAKE_CURRENT_SOURCE_DIR}/LICENSE.md DESTINATION ${CMAKE_INSTALL_DOCDIR} COMPONENT binary )
+
+ # Install public headers
+ # TODO: Fix me for flat directory layout. Should be ${CMAKE_INSTALL_INCLUDEDIR}
+-install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION include/hsa COMPONENT dev )
+-
+-# Legacy symlink - not packaged (CPack is bugged until ~3.18, see https://gitlab.kitware.com/cmake/cmake/-/merge_requests/4637)
+-install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/hsa_include_link DESTINATION hsa/include PERMISSIONS OWNER_WRITE OWNER_READ RENAME hsa )
+-
+-# Legacy symlinks.
+-if ( ${BUILD_SHARED_LIBS} )
+- install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so DESTINATION hsa/lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so COMPONENT binary)
+- install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so.${VERSION_MAJOR} DESTINATION hsa/lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so.${VERSION_MAJOR} COMPONENT binary)
+-endif ()
++install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hsa )
+
+ ## Configure and install package config file
+ # Record our usage data for clients find_package calls.