summaryrefslogtreecommitdiff
path: root/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-9999.ebuild')
-rw-r--r--dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-9999.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-9999.ebuild b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-9999.ebuild
index 878cf8bbc33d..1ca30c8a10ae 100644
--- a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-9999.ebuild
+++ b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-9999.ebuild
@@ -59,6 +59,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/856088
+ # https://github.com/ROCm/clr/issues/64
+ #
+ # Do not trust it for LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# Fix ld.lld linker error: https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/issues/155
append-ldflags $(test-flags-CCLD -Wl,--undefined-version)