summaryrefslogtreecommitdiff
path: root/dev-libs/rocm-hostcall
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rocm-hostcall')
-rw-r--r--dev-libs/rocm-hostcall/Manifest4
-rw-r--r--dev-libs/rocm-hostcall/files/rocm-hostcall-2.7.0-install-correctly.patch39
-rw-r--r--dev-libs/rocm-hostcall/metadata.xml14
-rw-r--r--dev-libs/rocm-hostcall/rocm-hostcall-2.7.0.ebuild34
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/rocm-hostcall/Manifest b/dev-libs/rocm-hostcall/Manifest
new file mode 100644
index 000000000000..f2afbc63ea07
--- /dev/null
+++ b/dev-libs/rocm-hostcall/Manifest
@@ -0,0 +1,4 @@
+AUX rocm-hostcall-2.7.0-install-correctly.patch 1460 BLAKE2B a635eb5e841db218d48fd70fe68956e13f496cc6beb33f37ad1cdc237fd9168f2f48fcec951b0904016b114008f6270bf2df3f91e2269e2db3055b9ecdc7726f SHA512 faa49431ca93dc446deed02706aac06ff7ed7f7877a9c5e4611e7b653feaf3eedaa9d1300c328f54663c082dd033a464aa90ce46b30b733573763c5f30245ced
+DIST rocm-hostcall-2.7.0.tar.gz 1500771 BLAKE2B 275ad4cab34d554f8a131101eda474926f7270a44a0af9941d8f1233c29b44b3efb3ba83c6b541d501a3e2fc751c591c0f6a993563bbacf539b5bcd04b23963b SHA512 afb4a7318c2e137db6ac0502041ed53e63783ec1ab458962b1b16f0f2f28e09ce2ae70d048b858740eca8bf06328858400a68bed4e91d7cfc4b7714a66d85bc9
+EBUILD rocm-hostcall-2.7.0.ebuild 866 BLAKE2B b49f21e9d48418cbb7831f41a340fc36301083589e28cef71e52a49abc7a1e2771d69507cc2b5f4c62914b5ca62efd40f9c5a7ff1530b842838f742c12d32d31 SHA512 8ca7162104c4045b2591f41c9b1d936d47f5ce7949458c68831cafe5e1d716aaf23fc3c2935f71303ac75d682576213bc629537ab9124217492c512aee54974e
+MISC metadata.xml 477 BLAKE2B ec5920ba7f035d1122905dc096529265b11b9c6f9bc5b65552d528891f76334b4f105b7339a3180760c31e10ccbca5a2454018d4ebd10d1884e27c742c6b59f6 SHA512 738e3d6ecfdae4b69714187789223b16a8483bd4e93d830af0898b5f536312011efb74f7af1f046a76dcd6169181b67dcf00a9188959551c865aabbb8e1ec259
diff --git a/dev-libs/rocm-hostcall/files/rocm-hostcall-2.7.0-install-correctly.patch b/dev-libs/rocm-hostcall/files/rocm-hostcall-2.7.0-install-correctly.patch
new file mode 100644
index 000000000000..f419674886a7
--- /dev/null
+++ b/dev-libs/rocm-hostcall/files/rocm-hostcall-2.7.0-install-correctly.patch
@@ -0,0 +1,39 @@
+https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/pull/18
+
+From 345025de5c6c470e36505ff70978b168c05a1a71 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Wed, 31 Jul 2019 11:18:56 -0400
+Subject: [PATCH] Install to standard locations using GNUInstallDirs
+
+Some distributions require 64 bit libraries to be installed to lib64, for example.
+Using GNUInstallDirs ensures that files are installed to the expected locations.
+---
+ CMakeLists.txt | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0f524e6..009bab7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -5,6 +5,8 @@ if (NOT UNIX)
+ message(FATAL_ERROR "No Windows support due to lack of signals")
+ endif()
+
++include(GNUInstallDirs)
++
+ find_path(HSA_HEADER hsa/hsa.h PATHS /opt/rocm/include)
+ if (NOT EXISTS ${HSA_HEADER})
+ message(FATAL_ERROR "Cannot find HSA headers. Please check the CMAKE_PREFIX_PATH")
+@@ -34,9 +36,9 @@ target_compile_options(amd_hostcall
+ target_compile_definitions(amd_hostcall
+ PRIVATE "${AMD_HOSTCALL_PRIVATE_COMPILE_DEFINITIONS}")
+
+-set(INCLUDE_INSTALL_DIR include)
+-set(LIB_INSTALL_DIR lib)
+-set(SHARE_INSTALL_DIR share)
++set(INCLUDE_INSTALL_DIR ${CMAKE_INSTALL_INCLUDEDIR})
++set(LIB_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR})
++set(SHARE_INSTALL_DIR ${CMAKE_INSTALL_DATADIR})
+ set(CONFIG_INSTALL_DIR ${LIB_INSTALL_DIR}/cmake/amd_hostcall)
+
+ install(TARGETS amd_hostcall
diff --git a/dev-libs/rocm-hostcall/metadata.xml b/dev-libs/rocm-hostcall/metadata.xml
new file mode 100644
index 000000000000..6b2718fcba0e
--- /dev/null
+++ b/dev-libs/rocm-hostcall/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">RadeonOpenCompute/ROCm-CompilerSupport</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Radeon Open Compute hostcall API
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-libs/rocm-hostcall/rocm-hostcall-2.7.0.ebuild b/dev-libs/rocm-hostcall/rocm-hostcall-2.7.0.ebuild
new file mode 100644
index 000000000000..848a8f3a5408
--- /dev/null
+++ b/dev-libs/rocm-hostcall/rocm-hostcall-2.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/lib/hostcall"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCm-CompilerSupport-roc-${PV}/lib/hostcall"
+ KEYWORDS="~amd64"
+fi
+PATCHES=(
+ "${FILESDIR}/${P}-install-correctly.patch"
+)
+
+DESCRIPTION="Radeon Open Compute hostcall API"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-libs/rocr-runtime"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/"
+ )
+ cmake-utils_src_configure
+}