summaryrefslogtreecommitdiff
path: root/dev-libs/rocclr/rocclr-4.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rocclr/rocclr-4.3.0.ebuild')
-rw-r--r--dev-libs/rocclr/rocclr-4.3.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/rocclr/rocclr-4.3.0.ebuild b/dev-libs/rocclr/rocclr-4.3.0.ebuild
new file mode 100644
index 000000000000..95a3dce4b948
--- /dev/null
+++ b/dev-libs/rocclr/rocclr-4.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Radeon Open Compute Common Language Runtime"
+HOMEPAGE="https://github.com/ROCm-Developer-Tools/ROCclr"
+SRC_URI="https://github.com/ROCm-Developer-Tools/ROCclr/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/archive/rocm-${PV}.tar.gz -> rocm-opencl-runtime-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/rocm-comgr:${SLOT}
+ dev-libs/rocr-runtime:${SLOT}"
+DEPEND="${RDEPEND}
+ virtual/opengl
+ dev-util/rocm-cmake:${SLOT}"
+
+PATCHES=(
+ "${FILESDIR}/rocclr-3.7.0-cmake-install-destination.patch"
+)
+
+S="${WORKDIR}/ROCclr-rocm-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_COMGR_LIBRARY=YES
+ -DOPENCL_DIR="${WORKDIR}/ROCm-OpenCL-Runtime-rocm-${PV}"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ )
+ cmake_src_configure
+}