summaryrefslogtreecommitdiff
path: root/dev-libs/pthreads4w
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/pthreads4w')
-rw-r--r--dev-libs/pthreads4w/Manifest3
-rw-r--r--dev-libs/pthreads4w/metadata.xml12
-rw-r--r--dev-libs/pthreads4w/pthreads4w-3.0.0.ebuild72
3 files changed, 0 insertions, 87 deletions
diff --git a/dev-libs/pthreads4w/Manifest b/dev-libs/pthreads4w/Manifest
deleted file mode 100644
index 2b447ed3e83e..000000000000
--- a/dev-libs/pthreads4w/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pthreads4w-code-v3.0.0.zip 862409 BLAKE2B cd23103c92f8eaa2088fdd68cfc94655771d44c365ca32180395cdb8645b570c2f65620d3c2969671a48c6ac45889bc439f3490dc7ec2497dfeca9f758cda6cd SHA512 49e541b66c26ddaf812edb07b61d0553e2a5816ab002edc53a38a897db8ada6d0a096c98a9af73a8f40c94283df53094f76b429b09ac49862465d8697ed20013
-EBUILD pthreads4w-3.0.0.ebuild 1758 BLAKE2B b0811ba0fea7612e58c80651375a2f82f6c62938c141290cfacec6916ea0641ab3f6612312f826d0021de7ac6893d9382d0a857198ee04f9fa9bd68767e777bb SHA512 92e288123115fdb5aa12c1fd8227f44d2371cc6ba0eed89fd0f942e1e3dc1d95edb842d78ed4b75fe0584d75e86089c66af42de6865f98346a6e7895295cc140
-MISC metadata.xml 458 BLAKE2B 68c251765a7bc10e18748d92fb94287125e8c46826d0ab4432b5496a2544fea368553fce7d2933866766542692760be927d7c753d564dbff4aa59ca4c59614b9 SHA512 9ce3ed661fc598134935bb3cf88a2d06085670ce35e159cc45ad0c89044b5bb9b8987fcf7c6012dc9a3e8f47ab21f1b4900d5e9e0cf291dd0d2c52145cf4319a
diff --git a/dev-libs/pthreads4w/metadata.xml b/dev-libs/pthreads4w/metadata.xml
deleted file mode 100644
index fc616b5907e1..000000000000
--- a/dev-libs/pthreads4w/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription lang="en">
- Also known as "pthreads-win32", POSIX Threads for Windows implements a large
- subset of the threads related API from the Single Unix Specification Version 3.
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">pthreads4w</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-libs/pthreads4w/pthreads4w-3.0.0.ebuild b/dev-libs/pthreads4w/pthreads4w-3.0.0.ebuild
deleted file mode 100644
index d320c03a21f0..000000000000
--- a/dev-libs/pthreads4w/pthreads4w-3.0.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="POSIX Threads for Windows"
-HOMEPAGE="http://pthreads4w.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-code-v${PV}.zip"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-BDEPEND="
- app-arch/unzip
- sys-devel/parity
-"
-
-S=${WORKDIR}/${PN}-code-07053a521b0a9deb6db2a649cde1f828f2eb1f4f
-
-src_compile() {
- # from pthreads.h:
- # Note: Unless the build explicitly defines one of the following, then
- # we default to standard C style cleanup. This style uses setjmp/longjmp
- # in the cancellation and thread exit implementations and therefore won't
- # do stack unwinding if linked to applications that have it (e.g.
- # C++ apps). This is currently consistent with most/all commercial Unix
- # POSIX threads implementations.
- local variant="VC" # C style cleanup
-
- case ${CHOST} in
- *-libcmtd*) variant+="-static-debug" ;;
- *-libcmt*) variant+="-static" ;;
- *-msvcd*) variant+="-debug" ;;
- *-msvc*) ;;
- esac
-
- case ${CHOST} in
- x86_64-*) variant+=" TARGET_CPU=x64" ;;
- i?86-*) variant+=" TARGET_CPU=x86" ;;
- esac
-
- ${CHOST}-nmake -f Makefile ${variant} || die
-}
-
-src_install() {
- local V=$(ver_cut 1)
- case ${CHOST} in
- *-libcmtd*|*-msvcd*) V+="d" ;; # debug CRT
- esac
- case ${CHOST} in
- *-libcmt*) # static CRT
- dolib.so libpthreadVC${V}.lib
- newlib.so libpthreadVC${V}.lib libpthread.lib # for -lpthread
- ;;
- *-msvc*) # dynamic CRT
- dobin pthreadVC${V}.dll
- dolib.so pthreadVC${V}.lib
- newlib.so pthreadVC${V}.lib pthread.lib # for -lpthread
- ;;
- esac
- insinto /usr/include
- doins {pthread,sched,semaphore,_ptw32}.h
- einstalldocs
-}
-
-src_test() {
- ${CHOST}-nmake -DEXHAUSTIVE all-tests || die
-}