summaryrefslogtreecommitdiff
path: root/dev-libs/protobuf
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/protobuf')
-rw-r--r--dev-libs/protobuf/Manifest2
-rw-r--r--dev-libs/protobuf/protobuf-9999.ebuild5
2 files changed, 3 insertions, 4 deletions
diff --git a/dev-libs/protobuf/Manifest b/dev-libs/protobuf/Manifest
index 007fa3c1778a..194f906309e2 100644
--- a/dev-libs/protobuf/Manifest
+++ b/dev-libs/protobuf/Manifest
@@ -46,5 +46,5 @@ EBUILD protobuf-27.5.ebuild 4098 BLAKE2B ebac46fe3198ada4f12aa5965c74a143a0526d3
EBUILD protobuf-28.0.ebuild 4116 BLAKE2B bbf35a188a559c2ce720d502befb96c85ffb44a889d70d09c959bb292eb7ee6d1516f07389554ebc1ae2fa37a2d990a7be3275332d7ff388429e54d10aefa5e7 SHA512 7dbe1d3a031cee32ef793c1a535ac47bc12d108029b451394446b7fe9d62b9b83bc88c1dc8d8094d4698a6942ef7573119b4a5423a49c6ac8663cc1778d05626
EBUILD protobuf-28.3-r1.ebuild 4278 BLAKE2B bb02aee6792a9773ae311add71bc8492cf33f3e38a30fc4799b7e0a462d82668c5ce5a62f299e778321b8a5f704b25cd51b97fee660bd879f8a6fc6505ce30c6 SHA512 c47411af0a205592f5cb42f62322525e4ae0ee70d523dd5d9f4d78e223288829949b3c2642d5e7b8e4380a1da12945258cc6fc3946f3cd2f49ce8a9ee6b01e64
EBUILD protobuf-29.2.ebuild 4225 BLAKE2B e7b3624a0621d5ba7d6beeebe19231a849cd926dc317e0111109a8b34f42f69e07e55e9da2284b360a46142f4e5e00b971e59e09bb5d83378ef072590f19331c SHA512 1d361fa2439bd0e373be128128c19db12d63edf7c89c2965731907148e58559269e028568348d409093a1feffa35efecdb0457e8fdc96f1fe8bbf7a2a35ca3f6
-EBUILD protobuf-9999.ebuild 4225 BLAKE2B e7b3624a0621d5ba7d6beeebe19231a849cd926dc317e0111109a8b34f42f69e07e55e9da2284b360a46142f4e5e00b971e59e09bb5d83378ef072590f19331c SHA512 1d361fa2439bd0e373be128128c19db12d63edf7c89c2965731907148e58559269e028568348d409093a1feffa35efecdb0457e8fdc96f1fe8bbf7a2a35ca3f6
+EBUILD protobuf-9999.ebuild 4205 BLAKE2B 59475b67b787d0679fb3185d940d549149b2cedeb031feef359e9eb60ff8a35439e875f8d0b84bb543fa9590310f81e0d2bd3a236bb754eccdf7a5de71af2555 SHA512 2e055cb7a7373bc7ce48f2c5af04e23385cf1c208bade755939eb008817a98bd00ee79ca51f14b8826d9626c4d5c7fbf2d28ab0fff6d04592d926cd8aab23620
MISC metadata.xml 917 BLAKE2B c25c810e47e764843ad71be5eb5ebe617d881e7363ce3206401eb59c6df12969bc22bbedc34f08b0a2fbcf955de5b85aa8e4d3a964c1349f07ed1d0eb344a915 SHA512 baa5737981669f1b28ce32884698a4d91e0f1fbdde6056779307e1a6c85dde8ca36ee47ca3ce8794b996934dfafc5482afbe9532a7f3e17c833c3aef0a330376
diff --git a/dev-libs/protobuf/protobuf-9999.ebuild b/dev-libs/protobuf/protobuf-9999.ebuild
index 3080cc281d8b..1106a4dfca74 100644
--- a/dev-libs/protobuf/protobuf-9999.ebuild
+++ b/dev-libs/protobuf/protobuf-9999.ebuild
@@ -14,20 +14,19 @@ ABSEIL_MIN_VER="${ABSEIL_MIN_VER//_/}"
if [[ "${PV}" == *9999 ]]; then
EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf.git"
EGIT_SUBMODULES=( '-*' )
- MY_SLOT="28.0"
+ SLOT="0/9999"
inherit git-r3
else
SRC_URI="https://github.com/protocolbuffers/protobuf/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
- MY_SLOT=$(ver_cut 1-2)
+ SLOT="0/$(ver_cut 1-2).0"
fi
DESCRIPTION="Google's Protocol Buffers - Extensible mechanism for serializing structured data"
HOMEPAGE="https://protobuf.dev/"
LICENSE="BSD"
-SLOT="0/${MY_SLOT}.0"
IUSE="conformance debug emacs examples +libprotoc libupb +protobuf +protoc test zlib"
# Require protobuf for the time being