summaryrefslogtreecommitdiff
path: root/dev-libs/popt/popt-1.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/popt/popt-1.18.ebuild')
-rw-r--r--dev-libs/popt/popt-1.18.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-libs/popt/popt-1.18.ebuild b/dev-libs/popt/popt-1.18.ebuild
index 435dcfdc5e35..cbbaee017f57 100644
--- a/dev-libs/popt/popt-1.18.ebuild
+++ b/dev-libs/popt/popt-1.18.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib-minimal libtool
+inherit flag-o-matic multilib-minimal libtool toolchain-funcs
DESCRIPTION="Parse Options - Command line parser"
HOMEPAGE="https://github.com/rpm-software-management/popt"
@@ -25,6 +25,13 @@ src_prepare() {
}
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myeconfargs=(
$(use_enable static-libs static)
$(use_enable nls)