summaryrefslogtreecommitdiff
path: root/dev-libs/poco/poco-1.9.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/poco/poco-1.9.0-r2.ebuild')
-rw-r--r--dev-libs/poco/poco-1.9.0-r2.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-libs/poco/poco-1.9.0-r2.ebuild b/dev-libs/poco/poco-1.9.0-r2.ebuild
index dabc308f3bb4..0e799b657b11 100644
--- a/dev-libs/poco/poco-1.9.0-r2.ebuild
+++ b/dev-libs/poco/poco-1.9.0-r2.ebuild
@@ -9,7 +9,7 @@ HOMEPAGE="https://pocoproject.org/"
SRC_URI="https://github.com/pocoproject/${PN}/archive/${P}-release.tar.gz -> ${P}.tar.gz"
LICENSE="Boost-1.0"
SLOT="0"
-KEYWORDS="amd64 arm ~x86"
+KEYWORDS="amd64 arm x86"
IUSE="7z cppparser +crypto +data examples +file2pagecompiler +json +pagecompiler iodbc libressl mariadb +mongodb mysql +net odbc pdf pocodoc sqlite +ssl test +util +xml +zip"
REQUIRED_USE="
@@ -54,7 +54,7 @@ src_prepare() {
# and tests requiring running DB-servers, internet connections, etc.
sed -i \
-e '/testsuite/d' \
- {Data/{MySQL,ODBC},MongoDB,Net,NetSSL_OpenSSL,PDF}/CMakeLists.txt || die
+ {Data/{MySQL,ODBC},MongoDB,Net,NetSSL_OpenSSL,PDF,Redis}/CMakeLists.txt || die
# Poco expands ~ using passwd, which does not match $HOME in the build environment
sed -i \
-e '/CppUnit_addTest.*testExpand/d' \
@@ -67,17 +67,20 @@ src_prepare() {
fi
if use mariadb ; then
- # Fix MariaDB detection
+ # Fix MariaDB detection
sed -i -e 's~/usr/include/mysql~~' \
-e 's/STATUS "Couldn/FATAL_ERROR "Couldn/' \
cmake/FindMySQL.cmake || die
else
- # Fix MySQL detection
+ # Fix MySQL detection
sed -i -e 's/mysqlclient_r/mysqlclient/' \
-e 's/STATUS "Couldn/FATAL_ERROR "Couldn/' \
cmake/FindMySQL.cmake || die
fi
+ # Add missing directory that breaks the build
+ mkdir -p Encodings/testsuite/data || die
+
cmake-utils_src_prepare
}
@@ -115,6 +118,10 @@ src_configure() {
cmake-utils_src_configure
}
+src_test() {
+ POCO_BASE="${S}" cmake-utils_src_test
+}
+
src_install() {
cmake-utils_src_install