summaryrefslogtreecommitdiff
path: root/dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild')
-rw-r--r--dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild b/dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild
index f07fa0d1b072..5005c8fa6602 100644
--- a/dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild
+++ b/dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild
@@ -68,7 +68,7 @@ pkg_setup() {
[[ ${MERGE_TYPE} == binary ]] && return
# must check in pkg_setup; sysctl don't work with userpriv!
- if has test ${FEATURES} && use sctp ; then
+ if use test && use sctp ; then
# test_ssl_new will fail with "Ensure SCTP AUTH chunks are enabled in kernel"
# if sctp.auth_enable is not enabled.
local sctp_auth_status=$(sysctl -n net.sctp.auth_enable 2>/dev/null)
@@ -98,7 +98,7 @@ src_prepare() {
eapply_user
- if has test ${FEATURES} && use sctp && has network-sandbox ${FEATURES} ; then
+ if use test && use sctp && has network-sandbox ${FEATURES} ; then
einfo "Disabling test '80-test_ssl_new.t' which is known to fail with FEATURES=network-sandbox ..."
rm test/recipes/80-test_ssl_new.t || die
fi