summaryrefslogtreecommitdiff
path: root/dev-libs/olm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/olm')
-rw-r--r--dev-libs/olm/Manifest4
-rw-r--r--dev-libs/olm/files/olm-3.2.15-cmake.patch59
-rw-r--r--dev-libs/olm/metadata.xml20
-rw-r--r--dev-libs/olm/olm-3.2.15.ebuild25
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-libs/olm/Manifest b/dev-libs/olm/Manifest
new file mode 100644
index 000000000000..2ad6787a709b
--- /dev/null
+++ b/dev-libs/olm/Manifest
@@ -0,0 +1,4 @@
+AUX olm-3.2.15-cmake.patch 1585 BLAKE2B 4de4f3e6e29792fc697f40dbc303ad630222491a4692a05a953b1db7518ae22a557acdc570e3f0bd3dc080bc46aae128ec380963ee5274506e446f678f26472b SHA512 025fd3dbc26d59d3b5db1ac3a77e72dee396acdf1b3c2ee2d3746a6b1e2cf2c6965083707d3fc7df88a6f0c62729601f5df7e262998c806d98d2159fd6dbbfb2
+DIST olm-3.2.15.tar.bz2 2744760 BLAKE2B 44486a63217998010a0bb7e01ff3315c88e139d686b97158e67af29b2f052912412541fb944a17c5d8931df9c641a73e521ef8d0ff352b80fe30bd6fb73b2e7b SHA512 81832766e477fc17908e8d1c49b5403d87b5977fd9102605d95ef2a3907619b7301e32fe0e18ec0f575b1f004ce248633307ff43b0f48bc9bb2313cdfefd6ea7
+EBUILD olm-3.2.15.ebuild 588 BLAKE2B 1ceb73994e70456bc96c3750b37624f1f39e205599b35a790a8da86d6ea840881943f0acb2944ba0a2af850016faf0f07d5c9caf42fe067d20c984dad02ce555 SHA512 948f390c31a2bd634799ed8668f464850c8098775ded0710a8dc1a35ab2cd482964ab6d9559dbb620cf4fce4d1fe269bd11339eb78ad90e1247d20ff89dae68b
+MISC metadata.xml 703 BLAKE2B e15af6cc88087ba2f7ed109a13e31908ab529ad52755403b4272170e7d8a89330539f1b735b03624ec3b45a2ef5d5c4f37ebc1d6f279ed49f852edfa2ae1f2ae SHA512 81c2896d8a489001e0ceffc99e97d20da679aba2fe83f2bea94cc7ddcaa3c09a52bf0c2266d53440fc6cbcecaf607a2b89193f8aa76ec6d50746cb3ab6ced7cb
diff --git a/dev-libs/olm/files/olm-3.2.15-cmake.patch b/dev-libs/olm/files/olm-3.2.15-cmake.patch
new file mode 100644
index 000000000000..d656bcbedbd4
--- /dev/null
+++ b/dev-libs/olm/files/olm-3.2.15-cmake.patch
@@ -0,0 +1,59 @@
+From 5567dc0ef9133df7cea5b9ae29c4fb642a8fbe83 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 8 Jun 2023 11:40:01 +0200
+Subject: [PATCH] Use CTest module and standard BUILD_TESTING switch
+
+Improves downstream package testing integration.
+
+See also:
+https://cmake.org/cmake/help/latest/command/enable_testing.html
+https://cmake.org/cmake/help/latest/module/CTest.html#module:CTest
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 5 +++--
+ tests/CMakeLists.txt | 2 --
+ 2 files changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a271b54..a62ea8f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,7 +2,6 @@ cmake_minimum_required(VERSION 3.4)
+
+ project(olm VERSION 3.2.15 LANGUAGES CXX C)
+
+-option(OLM_TESTS "Build tests" ON)
+ option(BUILD_SHARED_LIBS "Build as a shared library" ON)
+
+ add_definitions(-DOLMLIB_VERSION_MAJOR=${PROJECT_VERSION_MAJOR})
+@@ -52,6 +51,8 @@ add_library(olm
+ lib/curve25519-donna/curve25519-donna.c)
+ add_library(Olm::Olm ALIAS olm)
+
++include(CTest)
++
+ # restrict the exported symbols
+ include(GenerateExportHeader)
+ generate_export_header(olm
+@@ -137,6 +138,6 @@ export(EXPORT olm-targets
+ NAMESPACE Olm::)
+ export(PACKAGE Olm)
+
+-if (OLM_TESTS)
++if (BUILD_TESTING)
+ add_subdirectory(tests)
+ endif()
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 0343abb..64585ca 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -1,5 +1,3 @@
+-enable_testing()
+-
+ set(TEST_LIST
+ base64
+ crypto
+--
+2.41.0
+
diff --git a/dev-libs/olm/metadata.xml b/dev-libs/olm/metadata.xml
new file mode 100644
index 000000000000..e47db7bbc780
--- /dev/null
+++ b/dev-libs/olm/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <name>Gavin D. Howard</name>
+ <email>gavin@gavinhoward.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.matrix.org/matrix-org/olm</bugs-to>
+ <remote-id type="gitlab">matrix-org/olm</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Official, audited implementation of the olm and megolm cryptographic
+ ratchets in C++ for the Matrix protocol
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-libs/olm/olm-3.2.15.ebuild b/dev-libs/olm/olm-3.2.15.ebuild
new file mode 100644
index 000000000000..1146f6c87aa9
--- /dev/null
+++ b/dev-libs/olm/olm-3.2.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Implementation of the Double Ratchet cryptographic ratchet in C++"
+HOMEPAGE="https://gitlab.matrix.org/matrix-org/olm"
+SRC_URI="https://gitlab.matrix.org/matrix-org/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" ) # TODO: upstream
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}