summaryrefslogtreecommitdiff
path: root/dev-libs/nss/files/nss-3.53-fix-building-on-ppc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/nss/files/nss-3.53-fix-building-on-ppc.patch')
-rw-r--r--dev-libs/nss/files/nss-3.53-fix-building-on-ppc.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/nss/files/nss-3.53-fix-building-on-ppc.patch b/dev-libs/nss/files/nss-3.53-fix-building-on-ppc.patch
index be2d4802c4c2..962b9cb1eedb 100644
--- a/dev-libs/nss/files/nss-3.53-fix-building-on-ppc.patch
+++ b/dev-libs/nss/files/nss-3.53-fix-building-on-ppc.patch
@@ -1,9 +1,9 @@
https://bugzilla.mozilla.org/show_bug.cgi?id=1642174
-From 9e4f30b3168a95243df0c0891e3e432bc95382ad Mon Sep 17 00:00:00 2001
+From a7a862bab5e4aae4615ddae3cbe230345f92ed0d Mon Sep 17 00:00:00 2001
From: Lauri Kasanen <cand@gmx.com>
Date: Mon, 1 Jun 2020 12:11:45 +0300
-Subject: [PATCH v2] Bug 1642174 /usr/bin/ld: OBJS/Linux_SINGLE_SHLIB/sha512-p8.o:
+Subject: [PATCH v3] Bug 1642174 /usr/bin/ld: OBJS/Linux_SINGLE_SHLIB/sha512-p8.o:
ABI version 2 is not compatible with ABI version 1 output
Don't try to build the SHA-2 accelerated asm on old-ABI ppc.
@@ -17,7 +17,7 @@ Signed-off-by: Lauri Kasanen <cand@gmx.com>
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/lib/freebl/Makefile b/lib/freebl/Makefile
-index 5f7384429..d01587c7a 100644
+index 5f7384429..e0461c7d3 100644
--- a/lib/freebl/Makefile
+++ b/lib/freebl/Makefile
@@ -267,9 +267,12 @@ ifeq ($(CPU_ARCH),arm)
@@ -25,9 +25,9 @@ index 5f7384429..d01587c7a 100644
ifeq ($(CPU_ARCH),ppc)
EXTRA_SRCS += gcm-ppc.c
- ASFILES += sha512-p8.s
-+ PPC_ABI := $(shell $(CC) -dM -E - < /dev/null | grep _CALL_ELF | awk '{ print $3 }')
ifdef USE_64
DEFINES += -DNSS_NO_INIT_SUPPORT
++ PPC_ABI := $(shell $(CC) -dM -E - < /dev/null | awk '$$2 == "_CALL_ELF" {print $$3}')
+ ifeq ($(PPC_ABI),2)
+ ASFILES += sha512-p8.s
+ endif