summaryrefslogtreecommitdiff
path: root/dev-libs/mxml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mxml')
-rw-r--r--dev-libs/mxml/Manifest2
-rw-r--r--dev-libs/mxml/mxml-3.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/mxml/Manifest b/dev-libs/mxml/Manifest
index c8459960e1ea..1f2861826841 100644
--- a/dev-libs/mxml/Manifest
+++ b/dev-libs/mxml/Manifest
@@ -1,3 +1,5 @@
DIST mxml-3.0.tar.gz 9266886 BLAKE2B d5d3481cfd1d015c620ef897bfc21e839ad2a70f5ffd58973f8435e0e6a66abd477f8fcaacfab05ce608314fed27241702becb60b49b8492560bcc9418b317f5 SHA512 3c540348022226b122ce014f183368cda6631600a11d8f4d43c99c62fba2f3ca4b23dff4122082f63915b59a46a5475d1d12d0081f9315c65f5c044ac3c751d6
+DIST mxml-3.1.tar.gz 9267206 BLAKE2B d5cee24804978b474bf5b58c7a5932b50d7197a35e65da20c2517ce7db01d22027449348d6b15ddf0d186219ac81993055deaa4af9f48439273f8d2d74b27edd SHA512 8f8923b394093db5c471c52c17185916bc3c91f66c97de66919bfef2a09f271879a52f285e5fc4ded03484a3f83ba8fdb588d985b06e0c25ee001f1a80ffa586
EBUILD mxml-3.0.ebuild 1402 BLAKE2B 5ab3a112c010bd0a9a16ddc35c702138b22b88f4fc44dd0caa0f6227247ab19476978a81faf632753fba510e82fe2aa441e7e1ed81f041627c69dc9fb43d585b SHA512 1dbcf5b958c0e952d80c56079f0d3e21f91ab8a5b4e55dde68c71f152a0f4ea208f97b7f9fadd11178ef7379466c27df43674bac5e5f5cdaa08cc5645e2b0dad
+EBUILD mxml-3.1.ebuild 1406 BLAKE2B 586c9c5fb0b435cde055a066a6e74a8132df0716abd9bbb02ffba86b4ee17c13bcbcd3737e36a55d04b93094ac780a51221b0ba10fd7658df50d08765c0c399e SHA512 fed12172992949893b290de62c37ec5ee9409cf59ffc097c9957548fd9180597186599fc3e52d27079668b9f63f347e5ad53b31db47e315fb4e265f9ab142dad
MISC metadata.xml 1498 BLAKE2B b0ff99450cec828ef5614c2b3819d02cc97e402b60ce7b9bca20962166c47a9e3053e2457eb7b29210886aa7b0297e97340b55cf74a0aabc20ecb4c451d576c6 SHA512 5ead3d76daa42879139a96cceb0a12a84a23df8372a8e2e9e9d1e38ede0266b480ca404f03047f4e66ed7d989171d37333051e2a111dfa0900b9cbba703b22d6
diff --git a/dev-libs/mxml/mxml-3.1.ebuild b/dev-libs/mxml/mxml-3.1.ebuild
new file mode 100644
index 000000000000..d229322c4d4e
--- /dev/null
+++ b/dev-libs/mxml/mxml-3.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
+HOMEPAGE="
+ https://github.com/michaelrsweet/mxml
+ https://www.msweet.org/mxml/
+"
+SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs threads"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-Os -g//' -i configure.ac || die
+
+ # Don't run always tests
+ # Enable verbose compiling
+ sed -e '/ALLTARGETS/s/testmxml//g' -e '/.SILENT:/d' -i Makefile.in || die
+
+ # Build only static-libs, when requested by user, also build docs without static-libs in that case
+ if ! use static-libs; then
+ local mysedopts=(
+ -e '/^install:/s/install-libmxml.a//g'
+ -e '/^mxml.xml:/s/-static//g'
+ -e '/^mxml.epub:/s/-static//g'
+ -e '/^valgrind/s/-static//g'
+ -e 's/.\/mxmldoc-static/LD_LIBRARY_PATH="." .\/mxmldoc/g'
+ )
+ sed "${mysedopts[@]}" -i Makefile.in || die
+ fi
+
+ eautoconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable threads)
+ --with-docdir=/usr/share/doc/"${PF}"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake testmxml
+}
+
+src_install() {
+ emake DSTROOT="${ED}" install
+}