summaryrefslogtreecommitdiff
path: root/dev-libs/mxml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mxml')
-rw-r--r--dev-libs/mxml/Manifest4
-rw-r--r--dev-libs/mxml/mxml-3.0.ebuild62
-rw-r--r--dev-libs/mxml/mxml-3.1.ebuild2
3 files changed, 2 insertions, 66 deletions
diff --git a/dev-libs/mxml/Manifest b/dev-libs/mxml/Manifest
index c4094cdee95e..415f6d30e4f0 100644
--- a/dev-libs/mxml/Manifest
+++ b/dev-libs/mxml/Manifest
@@ -1,5 +1,3 @@
-DIST mxml-3.0.tar.gz 9266886 BLAKE2B d5d3481cfd1d015c620ef897bfc21e839ad2a70f5ffd58973f8435e0e6a66abd477f8fcaacfab05ce608314fed27241702becb60b49b8492560bcc9418b317f5 SHA512 3c540348022226b122ce014f183368cda6631600a11d8f4d43c99c62fba2f3ca4b23dff4122082f63915b59a46a5475d1d12d0081f9315c65f5c044ac3c751d6
DIST mxml-3.1.tar.gz 9267206 BLAKE2B d5cee24804978b474bf5b58c7a5932b50d7197a35e65da20c2517ce7db01d22027449348d6b15ddf0d186219ac81993055deaa4af9f48439273f8d2d74b27edd SHA512 8f8923b394093db5c471c52c17185916bc3c91f66c97de66919bfef2a09f271879a52f285e5fc4ded03484a3f83ba8fdb588d985b06e0c25ee001f1a80ffa586
-EBUILD mxml-3.0.ebuild 1402 BLAKE2B 5ab3a112c010bd0a9a16ddc35c702138b22b88f4fc44dd0caa0f6227247ab19476978a81faf632753fba510e82fe2aa441e7e1ed81f041627c69dc9fb43d585b SHA512 1dbcf5b958c0e952d80c56079f0d3e21f91ab8a5b4e55dde68c71f152a0f4ea208f97b7f9fadd11178ef7379466c27df43674bac5e5f5cdaa08cc5645e2b0dad
-EBUILD mxml-3.1.ebuild 1405 BLAKE2B 286c0a7a0d1f27c33fb2ce3e36c2035902c646df96d91855a902e99611f9296b32efcc0c114ebf27a9eef25191aa34e26e57f7918494fd253ec6eadcac61c8cc SHA512 46a932b365de48e6f646797a7abea283b390ea7f922fd6e2ad91f575fc41f084976b9a55c6db1e75f23f650d0139898aa85ae8e4147331408db85a84e74957e3
+EBUILD mxml-3.1.ebuild 1402 BLAKE2B f97955c73de42b8fcb7675c84ec741b53ac46d3a6001e59c9bd8cdab0dbaf62474c338e43f748e7281f58e3edc52c1cd9a3833964af859e6194623e1f1d11894 SHA512 e9d28e45c82f56fe3e619cff830242350bcd1f689aecce628ac6fa6d111a16bed95bfd1a36f7de1abb32fa9f284c92fd1519421332ba5a5f0f2b341ed6f5ac03
MISC metadata.xml 1379 BLAKE2B 9980eb701a13296c1f307c52427336ae892bd9905d86619bea889b3e4ad9fd3cd8dfbe23454c8a562a512628e83fd9cbd2100a2036e607bdf27585599481a9ec SHA512 d3a3de9e7b8ad130622bfa2e689bb1a944e1fb344961fda5ea39ad9fdba754e44bcb225a753834387e7bc490f25667a28422c79ef78ce4324ffb8706d0a71108
diff --git a/dev-libs/mxml/mxml-3.0.ebuild b/dev-libs/mxml/mxml-3.0.ebuild
deleted file mode 100644
index 11e653135297..000000000000
--- a/dev-libs/mxml/mxml-3.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
-HOMEPAGE="
- https://github.com/michaelrsweet/mxml
- https://www.msweet.org/mxml/
-"
-SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Mini-XML"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ~ppc64 ~sparc x86"
-IUSE="static-libs threads"
-
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- sed -e 's/-Os -g//' -i configure.ac || die
-
- # Don't run always tests
- # Enable verbose compiling
- sed -e '/ALLTARGETS/s/testmxml//g' -e '/.SILENT:/d' -i Makefile.in || die
-
- # Build only static-libs, when requested by user, also build docs without static-libs in that case
- if ! use static-libs; then
- local mysedopts=(
- -e '/^install:/s/install-libmxml.a//g'
- -e '/^mxml.xml:/s/-static//g'
- -e '/^mxml.epub:/s/-static//g'
- -e '/^valgrind/s/-static//g'
- -e 's/.\/mxmldoc-static/LD_LIBRARY_PATH="." .\/mxmldoc/g'
- )
- sed "${mysedopts[@]}" -i Makefile.in || die
- fi
-
- eautoconf
-}
-
-src_configure() {
- local myeconfopts=(
- $(use_enable threads)
- --with-docdir=/usr/share/doc/"${PF}"
- )
-
- econf "${myeconfopts[@]}"
-}
-
-src_test() {
- emake testmxml
-}
-
-src_install() {
- emake DSTROOT="${ED}" install
-}
diff --git a/dev-libs/mxml/mxml-3.1.ebuild b/dev-libs/mxml/mxml-3.1.ebuild
index 72c732d5c059..588f6e63e67c 100644
--- a/dev-libs/mxml/mxml-3.1.ebuild
+++ b/dev-libs/mxml/mxml-3.1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.ta
LICENSE="Mini-XML"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ~ppc64 ~sparc x86"
IUSE="static-libs threads"
BDEPEND="virtual/pkgconfig"