summaryrefslogtreecommitdiff
path: root/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild')
-rw-r--r--dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild b/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild
index 8c516b676e79..7a65b4b377ff 100644
--- a/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild
+++ b/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild
@@ -7,12 +7,15 @@ inherit multilib-minimal
# Upstream distribute patches before a new release is made
# See https://www.mpfr.org/mpfr-current/#bugs for the latest version (and patches)
+
+# Check whether any patches touch e.g. manuals!
+# https://archives.gentoo.org/gentoo-releng-autobuilds/message/c2dd39fc4ebc849db6bb0f551739e2ed
MY_PV=$(ver_cut 1-3)
MY_PATCH=$(ver_cut 5-)
MY_P=${PN}-${MY_PV}
DESCRIPTION="Library for multiple-precision floating-point computations with exact rounding"
-HOMEPAGE="https://www.mpfr.org/"
+HOMEPAGE="https://www.mpfr.org/ https://gitlab.inria.fr/mpfr"
SRC_URI="https://www.mpfr.org/${MY_P}/${MY_P}.tar.xz"
if [[ ${PV} == *_p* ]] ; then
# If this is a patch release, we have to download each of the patches:
@@ -48,6 +51,15 @@ fi
HTML_DOCS=( doc/FAQ.html )
+src_prepare() {
+ default
+
+ # 4.1.0_p13's patch10 patches a .texi file *and* the corresponding
+ # info file. We need to make sure the info file is newer, so the
+ # build doesn't try to run makeinfo. Won't be needed on next release.
+ touch "${S}/doc/mpfr.info" || die
+}
+
multilib_src_configure() {
# bug 476336#19
# Make sure mpfr doesn't go probing toolchains it shouldn't
@@ -57,7 +69,7 @@ multilib_src_configure() {
}
multilib_src_install_all() {
- rm "${ED}"/usr/share/doc/"${P}"/COPYING*
+ rm "${ED}"/usr/share/doc/${PF}/COPYING* || die
if ! use static-libs ; then
find "${ED}"/usr -name '*.la' -delete || die