summaryrefslogtreecommitdiff
path: root/dev-libs/mongo-c-driver/files/mongo-c-driver-1.12.0-libressl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mongo-c-driver/files/mongo-c-driver-1.12.0-libressl.patch')
-rw-r--r--dev-libs/mongo-c-driver/files/mongo-c-driver-1.12.0-libressl.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-libs/mongo-c-driver/files/mongo-c-driver-1.12.0-libressl.patch b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.12.0-libressl.patch
new file mode 100644
index 000000000000..e61bffafeed6
--- /dev/null
+++ b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.12.0-libressl.patch
@@ -0,0 +1,15 @@
+diff --git a/src/libmongoc/CMakeLists.txt b/src/libmongoc/CMakeLists.txt
+index d09d706..5d84225 100644
+--- a/src/libmongoc/CMakeLists.txt
++++ b/src/libmongoc/CMakeLists.txt
+@@ -109,7 +109,9 @@ if (NOT ENABLE_SSL STREQUAL OFF)
+ if (LIBRESSL_FOUND)
+ message ("-- Found ${LIBRESSL_LIBRARIES}")
+ set (SSL_LIBRARIES ${LIBRESSL_LIBRARIES})
+- include_directories ("${LIBRESSL_INCLUDE_DIRS}")
++ if (${LIBRESSL_INCLUDE_DIRS})
++ include_directories ("${LIBRESSL_INCLUDE_DIRS}")
++ endif ()
+ link_directories ("${LIBRESSL_LIBRARY_DIRS}")
+ set (LIBRESSL 1)
+ else ()